update aircrack-ng to v0.7 (closes: #1307), thanks to olg!
authorNicolas Thill <nico@openwrt.org>
Fri, 2 Feb 2007 00:32:22 +0000 (00:32 +0000)
committerNicolas Thill <nico@openwrt.org>
Fri, 2 Feb 2007 00:32:22 +0000 (00:32 +0000)
SVN-Revision: 6249

net/aircrack-ng/Makefile
net/aircrack-ng/patches/100-if_include.patch [new file with mode: 0644]
net/aircrack-ng/patches/100-net_if.patch [deleted file]

index a1215b0a2b1dcec0ceea3480593ca31fda2759b7..3fff4414d8262c05b9ceb35f0b7425e23ef55076 100644 (file)
@@ -9,12 +9,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=aircrack-ng
-PKG_VERSION:=0.6.2
+PKG_VERSION:=0.7
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://download.aircrack-ng.org/
-PKG_MD5SUM:=0b1a9fb6818822f933336efc9fff316b
+PKG_MD5SUM:=34c0447951d438d76fa32d08eab5da01
 PKG_CAT:=zcat
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
diff --git a/net/aircrack-ng/patches/100-if_include.patch b/net/aircrack-ng/patches/100-if_include.patch
new file mode 100644 (file)
index 0000000..c123286
--- /dev/null
@@ -0,0 +1,10 @@
+--- aircrack-ng-0.7.orig/src/airtun-ng.c     2007-02-02 00:01:36.000000000 +0100
++++ aircrack-ng-0.7/src/airtun-ng.c  2007-02-01 23:58:44.000000000 +0100
+@@ -32,6 +32,7 @@
+
+ #include <netpacket/packet.h>
+ #include <linux/if_ether.h>
++#include <linux/if.h>
+ #include <linux/wireless.h>
+ #include <arpa/inet.h>
+ #include <unistd.h>
diff --git a/net/aircrack-ng/patches/100-net_if.patch b/net/aircrack-ng/patches/100-net_if.patch
deleted file mode 100644 (file)
index 3856cbf..0000000
+++ /dev/null
@@ -1,28 +0,0 @@
-diff -urN aircrack-ng-0.6.2/src/aireplay-ng.c aircrack-ng-0.6.2.new/src/aireplay-ng.c
---- aircrack-ng-0.6.2/src/aireplay-ng.c        2006-09-24 20:28:42.000000000 +0200
-+++ aircrack-ng-0.6.2.new/src/aireplay-ng.c    2007-01-05 22:54:08.000000000 +0100
-@@ -29,6 +29,10 @@
- #include <sys/wait.h>
- #include <sys/time.h>
-+#include <linux/version.h>
-+#if LINUX_VERSION_CODE >= KERNEL_VERSION(2,6,19)
-+#include <net/if.h>
-+#endif
- #include <netpacket/packet.h>
- #include <linux/if_ether.h>
- #include <linux/wireless.h>
-diff -urN aircrack-ng-0.6.2/src/airodump-ng.c aircrack-ng-0.6.2.new/src/airodump-ng.c
---- aircrack-ng-0.6.2/src/airodump-ng.c        2006-09-09 16:38:26.000000000 +0200
-+++ aircrack-ng-0.6.2.new/src/airodump-ng.c    2007-01-05 22:55:00.000000000 +0100
-@@ -25,6 +25,10 @@
- #include <sys/wait.h>
- #include <sys/time.h>
-+#include <linux/version.h>
-+#if LINUX_VERSION_CODE >= KERNEL_VERSION(2,6,19)
-+#include <net/if.h>
-+#endif
- #include <netpacket/packet.h>
- #include <linux/if_ether.h>
- #include <linux/wireless.h>