[PATCH] split rsyncd into a separate package
authorJo-Philipp Wich <jow@openwrt.org>
Sun, 8 May 2011 11:05:21 +0000 (11:05 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Sun, 8 May 2011 11:05:21 +0000 (11:05 +0000)
Split rsyncd into a separate package

Make rsyncd a separate config option so that people who don't want an
rsync daemon using up RAM can still select the rsync client.  Depends
on rsync for the binary, the rsyncd package just consists of the init
script and configuration files.

Signed-off-by: Russell Senior <seniorr at aracnet.com>
SVN-Revision: 26852

net/rsync/Makefile

index b8478cc766bd6c9cc596eba32832d6ef420713f8..6548144a9f0bc35a189fc384316002805c36a716 100644 (file)
@@ -29,6 +29,14 @@ define Package/rsync
   URL:=http://rsync.samba.org/
 endef
 
   URL:=http://rsync.samba.org/
 endef
 
+define Package/rsyncd
+  SECTION:=net
+  CATEGORY:=Network
+  SUBMENU:=File Transfer
+  TITLE:=Rsync daemon
+  DEPENDS:=+rsync
+endef
+
 define Package/rsync/description
        rsync is a program that allows files to be copied to
        and from remote machines in much the same way as rcp.
 define Package/rsync/description
        rsync is a program that allows files to be copied to
        and from remote machines in much the same way as rcp.
@@ -49,12 +57,16 @@ CONFIGURE_ARGS += \
        --disable-acl-support \
 
 define Package/rsync/install
        --disable-acl-support \
 
 define Package/rsync/install
+       $(INSTALL_DIR) $(1)/usr/bin
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/$(PKG_NAME) $(1)/usr/bin/
+endef
+
+define Package/rsyncd/install
        $(INSTALL_DIR) $(1)/etc
        $(INSTALL_DATA) ./files/rsyncd.conf $(1)/etc/
        $(INSTALL_DIR) $(1)/etc/init.d
        $(INSTALL_BIN) ./files/rsyncd.init $(1)/etc/init.d/rsyncd
        $(INSTALL_DIR) $(1)/etc
        $(INSTALL_DATA) ./files/rsyncd.conf $(1)/etc/
        $(INSTALL_DIR) $(1)/etc/init.d
        $(INSTALL_BIN) ./files/rsyncd.init $(1)/etc/init.d/rsyncd
-       $(INSTALL_DIR) $(1)/usr/bin
-       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/$(PKG_NAME) $(1)/usr/bin/
 endef
 
 $(eval $(call BuildPackage,rsync))
 endef
 
 $(eval $(call BuildPackage,rsync))
+$(eval $(call BuildPackage,rsyncd))