kernel: deactivate ext4 SElinux support and extended attributes support
authorHauke Mehrtens <hauke@hauke-m.de>
Sun, 9 Jan 2011 22:43:06 +0000 (22:43 +0000)
committerHauke Mehrtens <hauke@hauke-m.de>
Sun, 9 Jan 2011 22:43:06 +0000 (22:43 +0000)
in general config. This effects the build in kmod-fs-ext4 and when it
is build into the kernel in the x86 target.

Thank you Philip Prindeville

SVN-Revision: 24951

package/kernel/modules/fs.mk
target/linux/generic/config-2.6.30
target/linux/generic/config-2.6.31
target/linux/generic/config-2.6.32
target/linux/generic/config-2.6.34
target/linux/generic/config-2.6.35
target/linux/generic/config-2.6.36
target/linux/generic/config-2.6.37

index e5714aab64475ab9d6ae78d0054bf129a5fe97ed..846bc8233f3cd5963c21746e9135985d0949c34f 100644 (file)
@@ -112,10 +112,6 @@ define KernelPackage/fs-ext4
   SUBMENU:=$(FS_MENU)
   TITLE:=EXT4 filesystem support
   KCONFIG:= \
-       CONFIG_EXT4DEV_COMPAT=n \
-       CONFIG_EXT4_FS_XATTR=y \
-       CONFIG_EXT4_FS_POSIX_ACL=y \
-       CONFIG_EXT4_FS_SECURITY=y \
        CONFIG_EXT4_FS \
        CONFIG_JBD2
   DEPENDS:= $(if $(DUMP)$(CONFIG_FS_MBCACHE),+kmod-fs-mbcache)
index 6e7d6a7965d04b50550aaf4911aa98bcc139cbc5..87e8c6dded3e652847b5940cf77665fbd83bc32f 100644 (file)
@@ -521,6 +521,8 @@ CONFIG_EXPERIMENTAL=y
 # CONFIG_EXT4DEV_COMPAT is not set
 # CONFIG_EXT4DEV_FS is not set
 # CONFIG_EXT4_FS is not set
+# CONFIG_EXT4_FS_SECURITY is not set
+# CONFIG_EXT4_FS_XATTR is not set
 CONFIG_EXTRA_FIRMWARE=""
 CONFIG_EXTRA_TARGETS=""
 # CONFIG_FAIR_GROUP_SCHED is not set
index e664748f53a0db0863704fb25bdb9854c51ceec5..96f955eeee6afcfdac8a8b2cb6f70c7518c9a9ae 100644 (file)
@@ -502,8 +502,11 @@ CONFIG_EXPERIMENTAL=y
 # CONFIG_EXT3_DEFAULTS_TO_ORDERED is not set
 # CONFIG_EXT3_FS is not set
 # CONFIG_EXT3_FS_XATTR is not set
+# CONFIG_EXT4DEV_COMPAT is not set
 # CONFIG_EXT4DEV_FS is not set
 # CONFIG_EXT4_FS is not set
+# CONFIG_EXT4_FS_SECURITY is not set
+# CONFIG_EXT4_FS_XATTR is not set
 CONFIG_EXTRA_FIRMWARE=""
 CONFIG_EXTRA_TARGETS=""
 # CONFIG_EZX_PCAP is not set
index 2e7756c532808963b74b482c329fb4d3d89c562f..5e3733ae649a9f39b7e8c0f7c6b2e7c71c57a755 100644 (file)
@@ -552,6 +552,7 @@ CONFIG_EXPERIMENTAL=y
 # CONFIG_EXT4DEV_FS is not set
 # CONFIG_EXT4_DEBUG is not set
 # CONFIG_EXT4_FS is not set
+# CONFIG_EXT4_FS_SECURITY is not set
 # CONFIG_EXT4_FS_XATTR is not set
 CONFIG_EXT4_USE_FOR_EXT23=y
 CONFIG_EXTRA_FIRMWARE=""
index 7f176181a49b09698631d5e57db21549f19b5c29..9209458ee21bd95788aa2790ebe603a6c0b987f0 100644 (file)
@@ -569,6 +569,8 @@ CONFIG_EXPERIMENTAL=y
 # CONFIG_EXT4DEV_FS is not set
 # CONFIG_EXT4_DEBUG is not set
 # CONFIG_EXT4_FS is not set
+# CONFIG_EXT4_FS_SECURITY is not set
+# CONFIG_EXT4_FS_XATTR is not set
 CONFIG_EXT4_USE_FOR_EXT23=y
 CONFIG_EXTRA_FIRMWARE=""
 CONFIG_EXTRA_TARGETS=""
index 8e1b16de7412a1d9c3b68debd174f8eb2c2a56c5..8f64f3414bb5c4f3a6daba6524d01afb5f3a4bb5 100644 (file)
@@ -594,6 +594,7 @@ CONFIG_EXPERIMENTAL=y
 # CONFIG_EXT4DEV_FS is not set
 # CONFIG_EXT4_DEBUG is not set
 # CONFIG_EXT4_FS is not set
+# CONFIG_EXT4_FS_SECURITY is not set
 # CONFIG_EXT4_FS_XATTR is not set
 CONFIG_EXT4_USE_FOR_EXT23=y
 CONFIG_EXTRA_FIRMWARE=""
index 0bc1175f4e1d80fa04ed5825580ae674d2cbee72..45dbde073cfe4ae380e80f408dd65462859ac059 100644 (file)
@@ -565,6 +565,7 @@ CONFIG_EXPERIMENTAL=y
 # CONFIG_EXT3_FS_XATTR is not set
 # CONFIG_EXT4_DEBUG is not set
 # CONFIG_EXT4_FS is not set
+# CONFIG_EXT4_FS_SECURITY is not set
 # CONFIG_EXT4_FS_XATTR is not set
 CONFIG_EXT4_USE_FOR_EXT23=y
 CONFIG_EXTRA_FIRMWARE=""
index 7e7685ae0216109a2b800816127ee24aa448ab41..b8fa6009eb8981bf07ba6a8614de66c335838b4d 100644 (file)
@@ -564,6 +564,7 @@ CONFIG_EXPERIMENTAL=y
 # CONFIG_EXT3_FS_XATTR is not set
 # CONFIG_EXT4_DEBUG is not set
 # CONFIG_EXT4_FS is not set
+# CONFIG_EXT4_FS_SECURITY is not set
 # CONFIG_EXT4_FS_XATTR is not set
 CONFIG_EXT4_USE_FOR_EXT23=y
 CONFIG_EXTRA_FIRMWARE=""