lantiq: ltq-vdsl-app: add dsl_cpe_pipe.sh
authorJohn Crispin <john@openwrt.org>
Tue, 24 Nov 2015 20:41:18 +0000 (20:41 +0000)
committerJohn Crispin <john@openwrt.org>
Tue, 24 Nov 2015 20:41:18 +0000 (20:41 +0000)
Signed-off-by: Hauke Mehrtens <hauke.mehrtens@lantiq.com>
SVN-Revision: 47636

package/network/config/ltq-vdsl-app/Makefile
package/network/config/ltq-vdsl-app/files/dsl_cpe_pipe.sh [new file with mode: 0755]

index 250d6f7664e37e0c9b99a6c05c25b6abe205f70c..b069421596285df76b39efe73a2bac3106d7eaba 100644 (file)
@@ -54,7 +54,8 @@ CONFIGURE_ARGS += \
        --disable-soap-support \
        --enable-dsl-bonding=no \
        --enable-debug-prints=err \
-       --disable-dti
+       --disable-dti \
+       --enable-debug
 
 ifeq ($(CONFIG_IFX_CLI),y)
 CONFIGURE_ARGS += \
@@ -73,6 +74,7 @@ define Package/ltq-vdsl-app/install
        $(INSTALL_BIN) ./files/vdsl_cpe_control_wrapper $(1)/sbin/
 
        $(INSTALL_BIN) $(PKG_BUILD_DIR)/src/dsl_cpe_control $(1)/sbin/vdsl_cpe_control
+       $(INSTALL_BIN) ./files/dsl_cpe_pipe.sh $(1)/sbin/
 endef
 
 $(eval $(call BuildPackage,ltq-vdsl-app))
diff --git a/package/network/config/ltq-vdsl-app/files/dsl_cpe_pipe.sh b/package/network/config/ltq-vdsl-app/files/dsl_cpe_pipe.sh
new file mode 100755 (executable)
index 0000000..30393b2
--- /dev/null
@@ -0,0 +1,18 @@
+#!/bin/sh
+
+pipe_no=0
+
+# use specified pipe no
+case "$1" in
+0|1|2)
+pipe_no=$1; shift; ;;
+esac
+
+
+#echo "Call dsl_pipe with $*"
+lock /var/lock/dsl_pipe
+echo $* > /tmp/pipe/dsl_cpe${pipe_no}_cmd
+result=`cat /tmp/pipe/dsl_cpe${pipe_no}_ack`
+lock -u /var/lock/dsl_pipe
+
+echo "$result"