merge r14180,r14181 to 8.09
authorFelix Fietkau <nbd@openwrt.org>
Sun, 25 Jan 2009 19:04:52 +0000 (19:04 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Sun, 25 Jan 2009 19:04:52 +0000 (19:04 +0000)
SVN-Revision: 14182

include/prereq-build.mk
tools/Makefile
tools/quilt/Makefile

index d6d2d73a63c39549936e19f5e2e4c2920f2fbd55..f0e1da9810d2f51c934cb63e364195e77ae69f2c 100644 (file)
@@ -37,6 +37,20 @@ $(eval $(call Require,case-sensitive-fs, \
        OpenWrt can only be built on a case-sensitive filesystem \
 ))
 
        OpenWrt can only be built on a case-sensitive filesystem \
 ))
 
+define Require/getopt
+       getopt --help 2>&1 | grep long >/dev/null
+endef
+$(eval $(call Require,getopt, \
+       Please install GNU getopt \
+))
+
+define Require/fileutils
+       gcp --help || cp --help
+endef
+$(eval $(call Require,fileutils, \
+       Please install GNU fileutils \
+))
+
 define Require/working-gcc
        echo 'int main(int argc, char **argv) { return 0; }' | \
                gcc -x c -o $(TMP_DIR)/a.out -
 define Require/working-gcc
        echo 'int main(int argc, char **argv) { return 0; }' | \
                gcc -x c -o $(TMP_DIR)/a.out -
index ecde1191baffdede062bdd1f6658c10468681d9b..e44fac4ad9fa11c731a5a99bd519afc155b80b96 100644 (file)
@@ -27,23 +27,20 @@ $(STAGING_DIR)/.prepared: $(TMP_DIR)/.build
        $(INSTALL_DATA) $(TOPDIR)/tools/include/*.h $(STAGING_DIR_HOST)/include/
        touch $@
 
        $(INSTALL_DATA) $(TOPDIR)/tools/include/*.h $(STAGING_DIR_HOST)/include/
        touch $@
 
-$(STAGING_DIR_HOST)/bin/md5sum: $(STAGING_DIR)/.prepared
-       @MD5SUM=`which md5sum 2>/dev/null`; \
-       if [ "$@" != "$$MD5SUM" ]; then \
-               if [ -x "$$MD5SUM" ]; then \
-                       ln -sf "$$MD5SUM" "$@"; \
-               else \
-                       cp $(SCRIPT_DIR)/md5sum $(STAGING_DIR_HOST)/bin/; \
-               fi; \
-       fi
-
-$(STAGING_DIR_HOST)/bin/find: $(STAGING_DIR)/.prepared
-       if [ -x "$(FIND)" -a "$(FIND)" != "$@" ]; then \
-               ln -sf "$(FIND)" $@; \
-       fi
-
-
-$(curdir)/cmddeps = $(patsubst %,$(STAGING_DIR_HOST)/bin/%,find md5sum)
+define PrepareCommand
+$(STAGING_DIR_HOST)/bin/$(1): $(STAGING_DIR)/.prepared
+       @mkdir -p "$$(dir $$@)"; rm -f "$$@"
+       @export FILE="$$$$(which $(2) 2>/dev/null | grep -v 'not found' | head -n1)"; [ -n "$$$$FILE" ] || { \
+               echo "Command $(1) not found."; false; \
+       }; ln -s "$$$$FILE" "$$@"
+
+endef
+
+$(eval $(call PrepareCommand,find,gfind find))
+$(eval $(call PrepareCommand,md5sum,md5sum $(SCRIPT_DIR)/md5sum))
+$(eval $(call PrepareCommand,cp,gcp cp))
+
+$(curdir)/cmddeps = $(patsubst %,$(STAGING_DIR_HOST)/bin/%,find md5sum cp)
 $(curdir)//prepare = $(STAGING_DIR)/.prepared $($(curdir)/cmddeps)
 $(curdir)//compile = $(STAGING_DIR)/.prepared $($(curdir)/cmddeps)
 
 $(curdir)//prepare = $(STAGING_DIR)/.prepared $($(curdir)/cmddeps)
 $(curdir)//compile = $(STAGING_DIR)/.prepared $($(curdir)/cmddeps)
 
index 49da92b7344f81ae5101baee49cf6120a3fe9a00..5294534b017552ba16ca8523abf95cd85fc5f58f 100644 (file)
@@ -15,6 +15,11 @@ PKG_MD5SUM:=d33d2442bd34387260b1c1db3e623af0
 
 include $(INCLUDE_DIR)/host-build.mk
 
 
 include $(INCLUDE_DIR)/host-build.mk
 
+define Build/Configure
+       $(call Build/Configure/Default)
+       [ -f $(PKG_BUILD_DIR)/Makefile ]
+endef
+
 define Build/Compile
        $(MAKE) -C $(PKG_BUILD_DIR) SHELL="$(BASH)"
 endef
 define Build/Compile
        $(MAKE) -C $(PKG_BUILD_DIR) SHELL="$(BASH)"
 endef