open-plc-utils: pass our CFLAGS and LDFLAGS for linking
authorFlorian Fainelli <florian@openwrt.org>
Sat, 8 Mar 2014 00:57:24 +0000 (00:57 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Sat, 8 Mar 2014 00:57:24 +0000 (00:57 +0000)
Signed-off-by: Florian Fainelli <florian@openwrt.org>
SVN-Revision: 39819

utils/open-plc-utils/Makefile

index 39ea4c1e9cd9022af646ba3a9ccf8e587fbcffcc..2137c5fb5bc682a5ee6c45e7029c71fde398be9b 100644 (file)
@@ -73,6 +73,7 @@ $(foreach a,$(OPEN_PLC_UTILS_APPS),$(eval $(call GenPlugin,$(a))))
 define Build/Compile
        $(MAKE) -C $(PKG_BUILD_DIR) \
                EXTRA_CFLAGS="$(TARGET_CPPFLAGS) $(TARGET_CFLAGS)" \
+               LDFLAGS="$(TARGET_CFLAGS) $(TARGET_LDFLAGS)" \
                CROSS="$(TARGET_CROSS)" \
                ROOTFS="$(PKG_INSTALL_DIR)" \
                OWNER="$(shell id -u $(shell whoami))" \