[packages] strace: fix compilation against Linux 2.6.32+ (#6604)
authorJo-Philipp Wich <jow@openwrt.org>
Sat, 30 Jan 2010 13:47:40 +0000 (13:47 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Sat, 30 Jan 2010 13:47:40 +0000 (13:47 +0000)
SVN-Revision: 19395

utils/strace/Makefile
utils/strace/patches/000-linux_socket.patch [new file with mode: 0644]

index 031b60f05ef59ad1094d92300fa0e37124e11422..17048e86cf156ef1a01c9acd4e0e2a17b807b6c7 100644 (file)
@@ -8,7 +8,7 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=strace
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=strace
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 ifeq ($(CONFIG_LINUX_2_6_25),y) 
   PKG_VERSION:=4.5.16
 
 ifeq ($(CONFIG_LINUX_2_6_25),y) 
   PKG_VERSION:=4.5.16
diff --git a/utils/strace/patches/000-linux_socket.patch b/utils/strace/patches/000-linux_socket.patch
new file mode 100644 (file)
index 0000000..a7c9f88
--- /dev/null
@@ -0,0 +1,24 @@
+diff -Nurb strace-4.5.19/configure strace-4.5.19-uClibc-0.9.30.2/configure
+--- strace-4.5.19/configure    2009-10-21 19:41:11.000000000 +0200
++++ strace-4.5.19-uClibc-0.9.30.2/configure    2010-01-29 14:41:35.897738564 +0100
+@@ -5880,7 +5880,7 @@
+ do :
+   as_ac_Header=`$as_echo "ac_cv_header_$ac_header" | $as_tr_sh`
+ ac_fn_c_check_header_compile "$LINENO" "$ac_header" "$as_ac_Header" "#include <stddef.h>
+-#include <linux/socket.h>
++#include <sys/socket.h>
+ "
+ eval as_val=\$$as_ac_Header
+    if test "x$as_val" = x""yes; then :
+diff -Nurb strace-4.5.19/configure.ac strace-4.5.19-uClibc-0.9.30.2/configure.ac
+--- strace-4.5.19/configure.ac 2009-10-12 21:54:43.000000000 +0200
++++ strace-4.5.19-uClibc-0.9.30.2/configure.ac 2010-01-29 14:42:02.880738326 +0100
+@@ -258,7 +258,7 @@
+ ], [], [])
+ AC_CHECK_HEADERS([linux/icmp.h linux/in6.h linux/netlink.h linux/if_packet.h],
+                  [], [], [#include <stddef.h>
+-#include <linux/socket.h>])
++#include <sys/socket.h>])
+ AC_CHECK_HEADERS([asm/sigcontext.h], [], [], [#include <signal.h>])
+ AC_CHECK_TYPES([struct sigcontext_struct,
+               struct sigcontext],,, [#include <signal.h>])