resync patches for 2.6.30-rc3
authorImre Kaloz <kaloz@openwrt.org>
Wed, 29 Apr 2009 20:46:49 +0000 (20:46 +0000)
committerImre Kaloz <kaloz@openwrt.org>
Wed, 29 Apr 2009 20:46:49 +0000 (20:46 +0000)
SVN-Revision: 15494

target/linux/generic-2.6/patches-2.6.30/004-extra_optimization.patch
target/linux/generic-2.6/patches-2.6.30/150-netfilter_imq.patch
target/linux/generic-2.6/patches-2.6.30/410-gpio_buttons.patch
target/linux/generic-2.6/patches-2.6.30/600-phy_extension.patch
target/linux/generic-2.6/patches-2.6.30/680-phy_ar8216.patch
target/linux/generic-2.6/patches-2.6.30/840-unable_to_open_console.patch
target/linux/generic-2.6/patches-2.6.30/922-gpiommc.patch
target/linux/generic-2.6/patches-2.6.30/980-vm_exports.patch

index 91dd68b914d222817d3a47749fbddfdeb825ef29..05fd5fbde445a9244b0814cb314dbcb0d7e16052 100644 (file)
@@ -1,6 +1,6 @@
 --- a/Makefile
 +++ b/Makefile
-@@ -561,6 +561,9 @@ endif
+@@ -566,6 +566,9 @@ endif
  NOSTDINC_FLAGS += -nostdinc -isystem $(shell $(CC) -print-file-name=include)
  CHECKFLAGS     += $(NOSTDINC_FLAGS)
  
index 634d222632c72785f8b6f9dfda427d6c63b4a34e..5760b8e9b6c8395b4e37f347265f1e603da09f8c 100644 (file)
        select CRC32
 --- a/drivers/net/Makefile
 +++ b/drivers/net/Makefile
-@@ -151,6 +151,7 @@ obj-$(CONFIG_SLHC) += slhc.o
+@@ -152,6 +152,7 @@ obj-$(CONFIG_SLHC) += slhc.o
  obj-$(CONFIG_XEN_NETDEV_FRONTEND) += xen-netfront.o
  
  obj-$(CONFIG_DUMMY) += dummy.o
index 6077906ae36a78692f08c4a2978c5a4fc858e715..139d997dfb75e9526626d8f65b5af74a7b95a7c0 100644 (file)
@@ -1,8 +1,8 @@
 --- a/drivers/input/misc/Kconfig
 +++ b/drivers/input/misc/Kconfig
-@@ -227,4 +227,20 @@ config INPUT_PCF50633_PMU
-        Say Y to include support for delivering  PMU events via  input
-        layer on NXP PCF50633.
+@@ -250,4 +250,20 @@ config INPUT_RB532_BUTTON
+         To compile this driver as a module, choose M here: the
+         module will be called rb532_button.
  
 +config INPUT_GPIO_BUTTONS
 +      tristate "Polled GPIO buttons interface"
@@ -23,8 +23,8 @@
  endif
 --- a/drivers/input/misc/Makefile
 +++ b/drivers/input/misc/Makefile
-@@ -22,3 +22,4 @@ obj-$(CONFIG_INPUT_UINPUT)           += uinput.o
- obj-$(CONFIG_INPUT_APANEL)            += apanel.o
- obj-$(CONFIG_INPUT_SGI_BTNS)          += sgi_btns.o
- obj-$(CONFIG_INPUT_PCF50633_PMU)      += pcf50633-input.o
+@@ -24,3 +24,4 @@ obj-$(CONFIG_INPUT_SPARCSPKR)                += sparcs
+ obj-$(CONFIG_INPUT_UINPUT)            += uinput.o
+ obj-$(CONFIG_INPUT_WISTRON_BTNS)      += wistron_btns.o
+ obj-$(CONFIG_INPUT_YEALINK)           += yealink.o
 +obj-$(CONFIG_INPUT_GPIO_BUTTONS)      += gpio_buttons.o
index 990d3cd8849f7b8869d32def8ea9f7a45ea89996..72a4fa52327324aa92f588206208b8b7412f9597 100644 (file)
@@ -73,7 +73,7 @@
        idx = phy_find_valid(idx, phydev->supported);
 --- a/include/linux/phy.h
 +++ b/include/linux/phy.h
-@@ -477,6 +477,7 @@ void phy_start_machine(struct phy_device
+@@ -483,6 +483,7 @@ void phy_start_machine(struct phy_device
  void phy_stop_machine(struct phy_device *phydev);
  int phy_ethtool_sset(struct phy_device *phydev, struct ethtool_cmd *cmd);
  int phy_ethtool_gset(struct phy_device *phydev, struct ethtool_cmd *cmd);
index 2e9bab10e363df45dedd7aa73731d1783ba7bad7..6cb3fd4170e873ebe005178c6f8d9136f189417b 100644 (file)
@@ -1,8 +1,8 @@
 --- a/drivers/net/phy/Kconfig
 +++ b/drivers/net/phy/Kconfig
-@@ -84,6 +84,10 @@ config IP175C_PHY
-       tristate "Driver for IC+ IP175C/IP178C switches"
-       select SWCONFIG
+@@ -96,6 +96,10 @@ config ADM6996_PHY
+ config MVSWITCH_PHY
+       tristate "Driver for Marvell 88E6060 switches"
  
 +config AR8216_PHY
 +      tristate "Driver for Atheros AR8216 switches"
@@ -16,8 +16,8 @@
 @@ -16,6 +16,7 @@ obj-$(CONFIG_ICPLUS_PHY)     += icplus.o
  obj-$(CONFIG_ADM6996_PHY)     += adm6996.o
  obj-$(CONFIG_MVSWITCH_PHY)    += mvswitch.o
- obj-$(CONFIG_IP175C_PHY)      += ip175c.o
-+obj-$(CONFIG_AR8216_PHY)      += ar8216.o
  obj-$(CONFIG_REALTEK_PHY)     += realtek.o
++obj-$(CONFIG_AR8216_PHY)      += ar8216.o
+ obj-$(CONFIG_LSI_ET1011C_PHY) += et1011c.o
  obj-$(CONFIG_FIXED_PHY)               += fixed.o
  obj-$(CONFIG_MDIO_BITBANG)    += mdio-bitbang.o
index 8d90396761391fd154676296b62b09499ad46b4d..c9a27746893275aefc8f5bebb1431c35b06dbee1 100644 (file)
@@ -1,6 +1,6 @@
 --- a/init/main.c
 +++ b/init/main.c
-@@ -807,7 +807,7 @@ static noinline int init_post(void)
+@@ -812,7 +812,7 @@ static noinline int init_post(void)
        numa_default_policy();
  
        if (sys_open((const char __user *) "/dev/console", O_RDWR, 0) < 0)
index 1d49b12136bc3b5b058977e8d2edb1037c9aecaf..dbfa823a868cd70b793a12abd504588ff7fbad80 100644 (file)
 +be done automatically.
 --- a/MAINTAINERS
 +++ b/MAINTAINERS
-@@ -1997,6 +1997,11 @@ L:      linux-media@vger.kernel.org
- T:    git kernel.org:/pub/scm/linux/kernel/git/mchehab/linux-2.6.git
+@@ -2490,6 +2490,11 @@ T:      git git://git.kernel.org/pub/scm/linu
  S:    Maintained
+ F:    drivers/media/video/gspca/
  
 +GPIOMMC DRIVER
 +P:    Michael Buesch
index ca2f052a4a57c53eb485c5cb5302a9010a09948a..6777383515b8395a87fb6c7a19b0012caf70dc6d 100644 (file)
@@ -1,6 +1,6 @@
 --- a/mm/shmem.c
 +++ b/mm/shmem.c
-@@ -2587,6 +2587,16 @@ int shmem_unuse(swp_entry_t entry, struc
+@@ -2602,6 +2602,16 @@ int shmem_unuse(swp_entry_t entry, struc
  
  /* common code */
  
@@ -17,7 +17,7 @@
  /**
   * shmem_file_setup - get an unlinked file living in tmpfs
   * @name: name for dentry (to be seen in /proc/<pid>/maps
-@@ -2665,11 +2675,7 @@ int shmem_zero_setup(struct vm_area_stru
+@@ -2680,11 +2690,7 @@ int shmem_zero_setup(struct vm_area_stru
        if (IS_ERR(file))
                return PTR_ERR(file);
  
@@ -70,7 +70,7 @@
   * macro override instead of weak attribute alias, to workaround
 --- a/kernel/sched.c
 +++ b/kernel/sched.c
-@@ -5600,6 +5600,7 @@ int can_nice(const struct task_struct *p
+@@ -5665,6 +5665,7 @@ int can_nice(const struct task_struct *p
        return (nice_rlim <= p->signal->rlim[RLIMIT_NICE].rlim_cur ||
                capable(CAP_SYS_NICE));
  }