Add bash from #1743
authorFlorian Fainelli <florian@openwrt.org>
Sun, 27 May 2007 19:02:12 +0000 (19:02 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Sun, 27 May 2007 19:02:12 +0000 (19:02 +0000)
SVN-Revision: 7361

utils/bash/Makefile [new file with mode: 0644]

diff --git a/utils/bash/Makefile b/utils/bash/Makefile
new file mode 100644 (file)
index 0000000..e8863fe
--- /dev/null
@@ -0,0 +1,60 @@
+#
+# Copyright (C) 2007 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+# $Id: $
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=bash
+PKG_VERSION:=3.2
+PKG_RELEASE:=1
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=ftp://ftp.gnu.org/gnu/bash/
+PKG_MD5SUM:=00bfa16d58e034e3c2aa27f390390d30
+PKG_CAT:=zcat
+
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
+PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/bash
+  SECTION:=utils
+  CATEGORY:=Utilities
+  TITLE:=The GNU Bourne Again SHell
+  DESCRIPTION:=\
+       Bash is an sh-compatible command language interpreter that executes \\\
+       commands read from the standard input or from a file.  Bash also \\\
+       incorporates useful features from the Korn and C shells (ksh and csh). 
+  URL:=http://www.gnu.org/software/bash/
+endef
+
+
+define Build/Configure 
+       $(call Build/Configure/Default, \
+               --disable-restricted \
+               --without-bash-malloc \
+                --bindir=/bin \
+       )
+endef
+
+
+define Build/Compile
+       $(MAKE) -C $(PKG_BUILD_DIR)/builtins LDFLAGS_FOR_BUILD= mkbuiltins
+       $(MAKE) -C $(PKG_BUILD_DIR) \
+               DESTDIR="$(PKG_INSTALL_DIR)" \
+               SHELL="/bin/bash" \
+               all install
+endef
+
+define Package/bash/install
+       $(INSTALL_DIR) $(1)/bin
+       $(CP) $(PKG_INSTALL_DIR)/bin/bash $(1)/bin/
+endef
+
+$(eval $(call BuildPackage,bash))
+