Fix endianness, install configuration file #3441
authorFlorian Fainelli <florian@openwrt.org>
Sun, 9 Nov 2008 18:03:57 +0000 (18:03 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Sun, 9 Nov 2008 18:03:57 +0000 (18:03 +0000)
SVN-Revision: 13161

net/psybnc/Makefile

index edf145a7c27888709c4b17438a8ae4f3b484e8a7..ecd3b0e27c7fbbf382a40aadda3e2686a0a6b707 100644 (file)
@@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=psybnc
 PKG_VERSION:=2.3.2-7
 
 PKG_NAME:=psybnc
 PKG_VERSION:=2.3.2-7
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=psyBNC-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://www.psybnc.info/download/beta/
 
 PKG_SOURCE:=psyBNC-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://www.psybnc.info/download/beta/
@@ -24,7 +24,6 @@ define Package/psybnc
   SUBMENU:=Instant Messaging
   SECTION:=net
   CATEGORY:=Network
   SUBMENU:=Instant Messaging
   SECTION:=net
   CATEGORY:=Network
-  DEPENDS:=
   TITLE:=An IRC-Bouncer with many features
   URL:=http://www.psybnc.info/
 endef
   TITLE:=An IRC-Bouncer with many features
   URL:=http://www.psybnc.info/
 endef
@@ -37,6 +36,12 @@ define Package/psybnc/description
        functions are included.
 endef
 
        functions are included.
 endef
 
+ifneq ($(SDK)$(CONFIG_BIG_ENDIAN),)
+  ENDIANESS:=1
+else
+  ENDIANESS:=0
+endif
+
 define Build/Compile   
        $(call Build/Compile/Default, \
                CFLAGS="$(TARGET_CFLAGS)" \
 define Build/Compile   
        $(call Build/Compile/Default, \
                CFLAGS="$(TARGET_CFLAGS)" \
@@ -45,6 +50,10 @@ define Build/Compile
        )
 endef
 
        )
 endef
 
+define Package/psybnc/conffiles
+/etc/psybnc.conf
+endef
+
 define Package/psybnc/install  
        $(INSTALL_DIR) $(1)/usr/sbin
        $(INSTALL_BIN) $(PKG_BUILD_DIR)/psybnc.sh $(1)/usr/sbin/psybnc
 define Package/psybnc/install  
        $(INSTALL_DIR) $(1)/usr/sbin
        $(INSTALL_BIN) $(PKG_BUILD_DIR)/psybnc.sh $(1)/usr/sbin/psybnc
@@ -53,6 +62,8 @@ define Package/psybnc/install
        $(INSTALL_CONF) $(PKG_BUILD_DIR)/psybnc.conf $(1)/usr/share/psybnc/
        $(INSTALL_DIR) $(1)/usr/share/psybnc/lang
        $(INSTALL_DATA) $(PKG_BUILD_DIR)/lang/english.lng $(1)/usr/share/psybnc/lang/
        $(INSTALL_CONF) $(PKG_BUILD_DIR)/psybnc.conf $(1)/usr/share/psybnc/
        $(INSTALL_DIR) $(1)/usr/share/psybnc/lang
        $(INSTALL_DATA) $(PKG_BUILD_DIR)/lang/english.lng $(1)/usr/share/psybnc/lang/
+       $(INSTALL_DIR) $(1)/etc/
+       $(INSTALL_CONF) $(PKG_BUILD_DIR)/psybnc.conf $(1)/etc
 endef
 
 $(eval $(call BuildPackage,psybnc))
 endef
 
 $(eval $(call BuildPackage,psybnc))