fix various compile issues
authorMike Baker <mbm@openwrt.org>
Wed, 6 Sep 2006 18:08:06 +0000 (18:08 +0000)
committerMike Baker <mbm@openwrt.org>
Wed, 6 Sep 2006 18:08:06 +0000 (18:08 +0000)
SVN-Revision: 4764

net/siproxd/Makefile

index 63468f0052a4d17e244153590a62ec7830cf38fe..2b8758e60b7d3398d20155b23d6668d96e2f2259 100644 (file)
@@ -44,13 +44,14 @@ define Build/Compile
        mkdir -p $(PKG_INSTALL_DIR)
        $(MAKE) -C $(PKG_BUILD_DIR) \
                DESTDIR="$(PKG_INSTALL_DIR)" \
+               SUBDIRS="src scripts contrib" \
                all install
 endef
 
 define Package/siproxd/install
        install -d -m0755 $(1)/etc
-       $(CP) $(PKG_INSTALL_DIR)/etc/siproxd.conf.example $(1)/etc/siproxd.conf
-       $(CP) $(PKG_INSTALL_DIR)/etc/siproxd_passwd.cfg $(1)/etc/
+       $(CP) $(PKG_BUILD_DIR)/doc/siproxd.conf.example $(1)/etc/siproxd.conf
+       $(CP) $(PKG_BUILD_DIR)/doc/siproxd_passwd.cfg $(1)/etc/
        install -d -m0755 $(1)/etc/init.d
        install -m0755 files/siproxd.init $(1)/etc/init.d/siproxd
        install -d -m0755 $(1)/usr/sbin