move perl/microperl in a 'Perl' submenu, cleanup
authorNicolas Thill <nico@openwrt.org>
Sun, 23 Sep 2007 18:17:39 +0000 (18:17 +0000)
committerNicolas Thill <nico@openwrt.org>
Sun, 23 Sep 2007 18:17:39 +0000 (18:17 +0000)
SVN-Revision: 8995

lang/perl/Makefile

index de6083639b359ed1f19d1ca86ac6f4b4ad4da44c..6b0aa96fc2fd793352f9a8b17d9bddcf1cd5e901 100644 (file)
@@ -18,21 +18,21 @@ PKG_SOURCE_URL:=ftp://ftp.cpan.org/pub/CPAN/src/5.0 \
                ftp://ftp.gmd.de/mirrors/CPAN/src/5.0 \
                ftp://ftp.funet.fi/pub/languages/perl/CPAN/src/5.0
 PKG_MD5SUM:=8d4aa4e061fd5bc0c39e4f0a63267880
-PKG_CAT:=zcat
-
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
 
 include $(INCLUDE_DIR)/package.mk
 
 define Package/microperl
-  SECTION:=utils
-  CATEGORY:=Utilities
+  SUBMENU:=Perl
+  SECTION:=lang
+  CATEGORY:=Languages
   TITLE:=A really minimal perl
-  DESCRIPTION:=\
-       A perl package without operating-specific functions such as readdir.
   URL:=http://www.perl.com/
 endef
 
+define Package/microperl/description
+ A perl package without operating-specific functions such as readdir.
+endef
+
 define Build/Configure
 endef
 
@@ -47,3 +47,4 @@ define Package/microperl/install
 endef
 
 $(eval $(call BuildPackage,microperl))
+