[packages] libs/avahi: update to version 0.6.21 (closes #2729)
authorGabor Juhos <juhosg@openwrt.org>
Sat, 8 Dec 2007 19:20:31 +0000 (19:20 +0000)
committerGabor Juhos <juhosg@openwrt.org>
Sat, 8 Dec 2007 19:20:31 +0000 (19:20 +0000)
SVN-Revision: 9679

libs/avahi/Makefile

index b4f14d57077673361cbb1537021317c5ed303b56..3d22f475141d7bcc2b7b494570091f1bd80d1334 100644 (file)
@@ -1,5 +1,5 @@
-# 
-# Copyright (C) 2006 OpenWrt.org
+#
+# Copyright (C) 2007 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,12 +9,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=avahi
-PKG_VERSION:=0.6.17
+PKG_VERSION:=0.6.21
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://avahi.org/download/
-PKG_MD5SUM:=29ebb2181958d5721ee5fc45f035a77c
+PKG_MD5SUM:=9cc68f79c50c9dd9e419990c3c9b05b9
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
 PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
@@ -40,12 +40,12 @@ endef
 
 define Package/libavahi/description
        An mDNS/DNS-SD (aka RendezVous/Bonjour/ZeroConf) implementation (library).
-       Avahi is a system which facilitates service discovery on a local network -- 
-       this means that you can plug your laptop or computer into a network and 
-       instantly be able to view other people who you can chat with, find printers 
-       to print to or find files being shared. This kind of technology is already 
-       found in MacOS X (branded 'Rendezvous', 'Bonjour' and sometimes 'ZeroConf') 
-       and is very convenient. 
+       Avahi is a system which facilitates service discovery on a local network --
+       this means that you can plug your laptop or computer into a network and
+       instantly be able to view other people who you can chat with, find printers
+       to print to or find files being shared. This kind of technology is already
+       found in MacOS X (branded 'Rendezvous', 'Bonjour' and sometimes 'ZeroConf')
+       and is very convenient.
        This package contains the mDNS/DNS-SD shared libraries, used by other programs.
 endef
 
@@ -57,17 +57,17 @@ endef
 
 define Package/avahi-autoipd/description
        An mDNS/DNS-SD (aka RendezVous/Bonjour/ZeroConf) implementation (library).
-       Avahi is a system which facilitates service discovery on a local network -- 
-       this means that you can plug your laptop or computer into a network and 
-       instantly be able to view other people who you can chat with, find printers 
-       to print to or find files being shared. This kind of technology is already 
-       found in MacOS X (branded 'Rendezvous', 'Bonjour' and sometimes 'ZeroConf') 
-       and is very convenient. 
-       This package implements IPv4LL, "Dynamic Configuration of 
-       IPv4 Link-Local Addresses" (IETF RFC3927), a protocol for 
-       automatic IP address configuration from the link-local 
-       169.254.0.0/16 range without the need for a central server. It 
-       is primarily intended to be used in ad-hoc networks which lack a 
+       Avahi is a system which facilitates service discovery on a local network --
+       this means that you can plug your laptop or computer into a network and
+       instantly be able to view other people who you can chat with, find printers
+       to print to or find files being shared. This kind of technology is already
+       found in MacOS X (branded 'Rendezvous', 'Bonjour' and sometimes 'ZeroConf')
+       and is very convenient.
+       This package implements IPv4LL, "Dynamic Configuration of
+       IPv4 Link-Local Addresses" (IETF RFC3927), a protocol for
+       automatic IP address configuration from the link-local
+       169.254.0.0/16 range without the need for a central server. It
+       is primarily intended to be used in ad-hoc networks which lack a
        DHCP server.
 endef
 
@@ -79,12 +79,12 @@ endef
 
 define Package/avahi-daemon/description
        An mDNS/DNS-SD (aka RendezVous/Bonjour/ZeroConf) implementation (library).
-       Avahi is a system which facilitates service discovery on a local network -- 
-       this means that you can plug your laptop or computer into a network and 
-       instantly be able to view other people who you can chat with, find printers 
-       to print to or find files being shared. This kind of technology is already 
-       found in MacOS X (branded 'Rendezvous', 'Bonjour' and sometimes 'ZeroConf') 
-       and is very convenient. 
+       Avahi is a system which facilitates service discovery on a local network --
+       this means that you can plug your laptop or computer into a network and
+       instantly be able to view other people who you can chat with, find printers
+       to print to or find files being shared. This kind of technology is already
+       found in MacOS X (branded 'Rendezvous', 'Bonjour' and sometimes 'ZeroConf')
+       and is very convenient.
        This package contains an mDNS/DNS-SD daemon.
 endef
 
@@ -101,8 +101,8 @@ define Package/avahi-dnsconfd
 endef
 
 define Package/avahi-dnsconfd/description
-       This package contains an Unicast DNS server from mDNS/DNS-SD configuration 
-       daemon, which may be used to configure conventional DNS servers using mDNS 
+       This package contains an Unicast DNS server from mDNS/DNS-SD configuration
+       daemon, which may be used to configure conventional DNS servers using mDNS
        in a DHCP-like fashion. Especially useful on IPv6.
 endef