[package] update vsftpd to 2.1.2 (#5647)
authorFlorian Fainelli <florian@openwrt.org>
Sun, 9 Aug 2009 10:25:28 +0000 (10:25 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Sun, 9 Aug 2009 10:25:28 +0000 (10:25 +0000)
SVN-Revision: 17191

net/vsftpd/Makefile
net/vsftpd/patches/001-destdir.patch
net/vsftpd/patches/002-find_libs.patch
net/vsftpd/patches/003-chroot.patch

index 4fd31e1a11ea95033683d08a30f1218b6e01bf4f..8085b623ff6a770ef3f74e8b1dddec685a803235 100644 (file)
@@ -8,12 +8,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=vsftpd
-PKG_VERSION:=2.1.1
+PKG_VERSION:=2.1.2
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=ftp://vsftpd.beasts.org/users/cevans/
-PKG_MD5SUM:=b1fab0e6212738f9f3572e067c419778
+PKG_MD5SUM:=6a8c8579d50adf0d0fc07226c03bfb52
 
 include $(INCLUDE_DIR)/package.mk
 
index d729e89ff2cdc2fca8dad64301914d59619151b3..33897b2b341caa889382159c21f13c3aaf596a2b 100644 (file)
@@ -1,9 +1,7 @@
-Index: vsftpd-2.0.6/Makefile
-===================================================================
---- vsftpd-2.0.6.orig/Makefile 2008-04-13 11:41:08.000000000 +0200
-+++ vsftpd-2.0.6/Makefile      2008-04-13 11:41:08.000000000 +0200
-@@ -17,6 +17,8 @@
-     ssl.o sysutil.o sysdeputil.o
+--- a/Makefile
++++ b/Makefile
+@@ -17,6 +17,8 @@ OBJS =       main.o utility.o prelogin.o ftpcm
+     ssl.o sslslave.o ptracesandbox.o ftppolicy.o sysutil.o sysdeputil.o
  
  
 +DESTDIR =
@@ -11,7 +9,7 @@ Index: vsftpd-2.0.6/Makefile
  .c.o:
        $(CC) -c $*.c $(CFLAGS) $(IFLAGS)
  
-@@ -24,21 +26,20 @@
+@@ -24,21 +26,20 @@ vsftpd: $(OBJS) 
        $(CC) -o vsftpd $(OBJS) $(LINK) $(LIBS) $(LDFLAGS)
  
  install:
index 86caffc640c03f6797d9ec56361e985b42f28d71..11a0308c9cb8468bcad252a9dd298af27973a6cf 100644 (file)
@@ -1,8 +1,6 @@
-Index: vsftpd-2.0.6/Makefile
-===================================================================
---- vsftpd-2.0.6.orig/Makefile 2008-04-13 11:41:08.000000000 +0200
-+++ vsftpd-2.0.6/Makefile      2008-04-13 11:41:08.000000000 +0200
-@@ -5,8 +5,8 @@
+--- a/Makefile
++++ b/Makefile
+@@ -5,8 +5,8 @@ IFLAGS  = -idirafter dummyinc
  #CFLAGS = -g
  CFLAGS        =       -O2 -Wall -W -Wshadow #-pedantic -Werror -Wconversion
  
index 4765c580043f04a4bfcb816394994da51d1d5cdd..bf7318e4f76e5260876c2486ab604d36cbeb2613 100644 (file)
@@ -1,8 +1,6 @@
-Index: vsftpd-2.0.6/tunables.c
-===================================================================
---- vsftpd-2.1.0.orig/tunables.c       2008-04-13 11:41:08.000000000 +0200
-+++ vsftpd-2.1.0/tunables.c    2008-04-13 11:41:09.000000000 +0200
-@@ -242,7 +242,7 @@
+--- a/tunables.c
++++ b/tunables.c
+@@ -244,7 +244,7 @@ tunables_load_defaults()
    /* -rw------- */
    tunable_chown_upload_mode = 0600;