only rebuild the package index when the *.ipk files have changed
authorMike Baker <mbm@openwrt.org>
Wed, 2 Aug 2006 13:06:58 +0000 (13:06 +0000)
committerMike Baker <mbm@openwrt.org>
Wed, 2 Aug 2006 13:06:58 +0000 (13:06 +0000)
SVN-Revision: 4395

openwrt/package/Makefile

index 85f852fd54d482728ccc40d43b4e5bde6086db7b..c2015b3a411ec9d6736805a7ac842861927f1976 100644 (file)
@@ -55,6 +55,8 @@ install:
        rm -rf $(BUILD_DIR)/root
        $(MAKE) install-targets
 
-index: FORCE
+index: $(PACKAGE_DIR)/Packages
+
+$(PACKAGE_DIR)/Packages: $(PACKAGE_DIR)/*.ipk
        (cd $(PACKAGE_DIR); $(STAGING_DIR)/usr/bin/ipkg-make-index . > Packages)