Addded fakeidentd, a lightweight and secure ident daemon
authorFlorian Fainelli <florian@openwrt.org>
Mon, 24 Apr 2006 12:05:30 +0000 (12:05 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Mon, 24 Apr 2006 12:05:30 +0000 (12:05 +0000)
SVN-Revision: 3703

openwrt/package/Config.in
openwrt/package/Makefile
openwrt/package/fakeidentd/Config.in [new file with mode: 0644]
openwrt/package/fakeidentd/Makefile [new file with mode: 0644]
openwrt/package/fakeidentd/files/fakeidentd.init [new file with mode: 0644]
openwrt/package/fakeidentd/ipkg/fakeidentd.control [new file with mode: 0644]

index 584d2aa4a2bb6bc7681c4345cfdddbd7b0823d1f..77fc7b1e7123dfbbf8ce2c9f11604a940af86bc4 100644 (file)
@@ -39,6 +39,7 @@ source "package/dropbear/Config.in"
 source "package/dsniff/Config.in"
 source "package/ebtables/Config.in"
 source "package/ez-ipupdate/Config.in"
+source "package/fakeidentd/Config.in"
 source "package/fping/Config.in"
 source "package/fprobe/Config.in"
 source "package/freeradius/Config.in"
index 41f8cec90cd4c93a8b8150635132ebe6b48ecfb0..f6838794e8b08bd54c3719d4698298682e138c7b 100644 (file)
@@ -20,6 +20,7 @@ package-$(BR2_PACKAGE_DROPBEAR) += dropbear
 package-$(BR2_PACKAGE_DSNIFF) += dsniff
 package-$(BR2_PACKAGE_EBTABLES) += ebtables
 package-$(BR2_PACKAGE_EZIPUPDATE) += ez-ipupdate
+package-$(BR2_PACKAGE_FAKEIDENTD) += fakeidentd
 package-$(BR2_PACKAGE_FPING) += fping
 package-$(BR2_PACKAGE_FPROBE) += fprobe
 package-$(BR2_PACKAGE_FREERADIUS) += freeradius
diff --git a/openwrt/package/fakeidentd/Config.in b/openwrt/package/fakeidentd/Config.in
new file mode 100644 (file)
index 0000000..5ae23a4
--- /dev/null
@@ -0,0 +1,8 @@
+config BR2_PACKAGE_FAKEIDENTD
+       prompt "fakeidentd - A static, secure identd."
+       tristate
+       default m if CONFIG_DEVEL
+       help
+         A static secure identd, only one source file.
+       
+         http://www.guru-group.fi/~too/sw/releases/
diff --git a/openwrt/package/fakeidentd/Makefile b/openwrt/package/fakeidentd/Makefile
new file mode 100644 (file)
index 0000000..f4050aa
--- /dev/null
@@ -0,0 +1,37 @@
+# $Id: $
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=fakeidentd
+PKG_VERSION:=2.2
+PKG_RELEASE:=1
+PKG_MD5SUM:=3aaf9d525da08ae18dd4133de4ff7be3
+
+PKG_SOURCE_URL:=@openwrt/
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
+PKG_CAT:=bzcat
+
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
+PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+
+include $(TOPDIR)/package/rules.mk
+
+$(eval $(call PKG_template,FAKEIDENTD,$(PKG_NAME),$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
+
+$(PKG_BUILD_DIR)/.configured:
+       touch $@
+
+$(PKG_BUILD_DIR)/.built:
+       $(TARGET_CC) -o $(PKG_BUILD_DIR)/$(PKG_NAME) $(PKG_BUILD_DIR)/identd.c
+       touch $@
+
+$(IPKG_FAKEIDENTD):
+       install -d -m0755 $(IDIR_FAKEIDENTD)/usr/sbin \
+                         $(IDIR_FAKEIDENTD)/etc/init.d \
+                         $(IDIR_FAKEIDENTD)/etc/default/
+       echo $(whoami) > $(IDIR_FAKEIDENTD)/etc/default/$(PKG_NAME)
+       cp -fpR $(PKG_BUILD_DIR)/fakeidentd $(IDIR_FAKEIDENTD)/usr/sbin/
+       cp -fpR ./files/$(PKG_NAME).init $(IDIR_FAKEIDENTD)/etc/init.d/$(PKG_NAME)
+       $(RSTRIP) $(IDIR_FAKEIDENTD)
+       $(IPKG_BUILD) $(IDIR_FAKEIDENTD) $(PACKAGE_DIR)
+
diff --git a/openwrt/package/fakeidentd/files/fakeidentd.init b/openwrt/package/fakeidentd/files/fakeidentd.init
new file mode 100644 (file)
index 0000000..3d6ddc1
--- /dev/null
@@ -0,0 +1,19 @@
+#!/bin/sh
+NAME=fakeidentd
+case "$1" in
+  start)
+       iptables -A input_rule -p tcp --dport 113 -j ACCEPT
+       [ -e $DEFAULT ] && $NAME $DEFAULT
+       ;;
+  stop)
+        killall $NAME
+       ;;
+  restart)
+       killall $NAME
+       $NAME
+       ;;
+  *)
+       echo "Usage: $NAME (start|stop|restart)" > 2&
+       exit 1
+       ;;
+esac
diff --git a/openwrt/package/fakeidentd/ipkg/fakeidentd.control b/openwrt/package/fakeidentd/ipkg/fakeidentd.control
new file mode 100644 (file)
index 0000000..6c528b2
--- /dev/null
@@ -0,0 +1,4 @@
+Package: fakeidentd
+Description: A static, secure identd.
+Section: net
+Priority: optional