Add libidn
authorFlorian Fainelli <florian@openwrt.org>
Wed, 28 Jan 2009 11:29:33 +0000 (11:29 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Wed, 28 Jan 2009 11:29:33 +0000 (11:29 +0000)
SVN-Revision: 14236

libs/libidn/Makefile [new file with mode: 0644]

diff --git a/libs/libidn/Makefile b/libs/libidn/Makefile
new file mode 100644 (file)
index 0000000..d61506f
--- /dev/null
@@ -0,0 +1,59 @@
+# Copyright (C) 2009 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+# $Id: $
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=libidn
+PKG_VERSION:=1.12
+PKG_RELEASE:=1
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=@GNU/libidn
+PKG_MD5SUM:=49db2165868d3ec2af00e0b7d0924dd8
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/libidn
+  SECTION:=libs
+  CATEGORY:=Libraries
+  TITLE:=Stringprep, Punycode and IDNA implementation
+  URL:=http://www.gnu.org/software/libidn/
+endef
+
+define Package/libgmp/description
+  GNU Libidn is a fully documented implementation of the Stringprep,
+  Punycode and IDNA specifications. Libidn's purpose is to encode and
+  decode internationalized domain names.
+endef
+
+TARGET_CFLAGS += $(FPIC)
+CONFIGURE_VARS += CC="$(TARGET_CROSS)gcc"
+CONFIGURE_ARGS += \
+       --enable-shared \
+       --enable-static \
+
+define Build/Compile
+       $(call Build/Compile/Default, \
+               DESTDIR="$(PKG_INSTALL_DIR)" \
+               CC="$(TARGET_CC)" \
+               all install \
+       )
+endef
+
+define Build/InstallDev
+       mkdir -p $(1)/usr/include
+       $(CP) $(PKG_INSTALL_DIR)/usr/include/*.h $(1)/usr/include/
+       mkdir -p $(1)/usr/lib
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libidn.{a,so*} $(1)/usr/lib/
+endef
+
+define Package/libidn/install
+       $(INSTALL_DIR) $(1)/usr/lib
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libidn.so.* $(1)/usr/lib/
+endef
+
+$(eval $(call BuildPackage,libidn))