update openssl to new upstream release (v0.9.7i),
authorNicolas Thill <nico@openwrt.org>
Thu, 20 Oct 2005 04:10:38 +0000 (04:10 +0000)
committerNicolas Thill <nico@openwrt.org>
Thu, 20 Oct 2005 04:10:38 +0000 (04:10 +0000)
enable engine support.

SVN-Revision: 2187

openwrt/package/openssl/Makefile
openwrt/package/openssl/patches/150-remove-fips.patch

index f1e6c5ed9030110d19a710be58fdc634f3f0e59e..b76f02ef7e8c391d4197d114126850c39186ddb9 100644 (file)
@@ -3,9 +3,9 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=openssl
-PKG_VERSION:=0.9.7g
+PKG_VERSION:=0.9.7i
 PKG_RELEASE:=1
-PKG_MD5SUM:=991615f73338a571b6a1be7d74906934
+PKG_MD5SUM:=f69d82b206ff8bff9d0e721f97380b9e
 
 PKG_SOURCE_URL:=http://www.openssl.org/source/ \
        ftp://ftp.funet.fi/pub/crypt/cryptography/libs/openssl/source/ \
@@ -36,7 +36,7 @@ $(PKG_BUILD_DIR)/.configured:
                  -I$(STAGING_DIR)/usr/include \
                  -L$(STAGING_DIR)/usr/lib -ldl \
                  $(OPENSSL_NO_CIPHERS) \
-                 shared no-asm no-ec no-engine no-err no-fips no-hw no-krb5 no-threads zlib-dynamic \
+                 shared no-asm no-ec no-err no-fips no-hw no-krb5 no-threads zlib-dynamic \
        )
        touch $@
 
index 3af1550a3061fd54bd4995ae0fc4890db1a23825..e4e3cb48703999452346a27baf498eb2793d44c7 100644 (file)
@@ -1,11 +1,21 @@
-diff -Nur openssl-0.9.7f/Makefile.org openssl-0.9.7f.new/Makefile.org
---- openssl-0.9.7f/Makefile.org        2005-03-15 10:46:13.000000000 +0100
-+++ openssl-0.9.7f.new/Makefile.org    2005-04-03 20:15:26.000000000 +0200
-@@ -229,7 +229,6 @@
+diff -ruN openssl-0.9.7h-old/Makefile.org openssl-0.9.7h-new/Makefile.org
+--- openssl-0.9.7h-old/Makefile.org    2005-10-12 23:12:38.000000000 +0200
++++ openssl-0.9.7h-new/Makefile.org    2005-10-12 23:13:38.000000000 +0200
+@@ -230,7 +230,6 @@
  libcrypto.a.sha1: libcrypto.a
        @if egrep 'define OPENSSL_FIPS' $(TOP)/include/openssl/opensslconf.h > /dev/null; then \
                $(RANLIB) libcrypto.a; \
--              fips/sha1/fips_standalone_sha1 libcrypto.a > libcrypto.a.sha1; \
+-              fips/sha/fips_standalone_sha1 libcrypto.a > libcrypto.a.sha1; \
        fi
  
  sub_all:
+@@ -258,9 +257,6 @@
+ libcrypto$(SHLIB_EXT): libcrypto.a
+       @if [ "$(SHLIB_TARGET)" != "" ]; then \
+               $(MAKE) SHLIBDIRS=crypto build-shared; \
+-              if egrep 'define OPENSSL_FIPS' $(TOP)/include/openssl/opensslconf.h > /dev/null; then \
+-                    fips/sha/fips_standalone_sha1 -binary $@ > $@.$${HMAC_EXT:-sha1}; \
+-              fi; \
+       else \
+               echo "There's no support for shared libraries on this platform" >&2; \
+       fi