stm32flash: make sure we pass our CFLAGS
authorFlorian Fainelli <florian@openwrt.org>
Sat, 8 Mar 2014 00:57:34 +0000 (00:57 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Sat, 8 Mar 2014 00:57:34 +0000 (00:57 +0000)
Signed-off-by: Florian Fainelli <florian@openwrt.org>
SVN-Revision: 39823

utils/stm32flash/Makefile
utils/stm32flash/patches/001-cflags_override.patch [new file with mode: 0644]

index 6d4af92b30f09077e9329bbe4f7e3e68a91b477e..19d2d47bff9f9baeb67da3684e375de961d0c125 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2012 OpenWrt.org
+# Copyright (C) 2012-2014 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
 PKG_NAME:=stm32flash
 PKG_REV:=61
 PKG_VERSION:=r$(PKG_REV)
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=http://stm32flash.googlecode.com/svn/trunk
diff --git a/utils/stm32flash/patches/001-cflags_override.patch b/utils/stm32flash/patches/001-cflags_override.patch
new file mode 100644 (file)
index 0000000..d8ba6f8
--- /dev/null
@@ -0,0 +1,30 @@
+--- a/Makefile
++++ b/Makefile
+@@ -5,7 +5,7 @@ export AR
+ all:
+       $(MAKE) -C parsers
+-      $(CC) -g -o stm32flash -I./ \
++      $(CC) $(LDFLAGS) -o stm32flash -I./ \
+               main.c \
+               utils.c \
+               stm32.c \
+@@ -13,7 +13,7 @@ all:
+               serial_platform.c \
+               parsers/parsers.a \
+               stm32/stmreset_binary.c \
+-              -Wall
++              $(CFLAGS)
+ clean:
+       $(MAKE) -C parsers clean
+--- a/parsers/Makefile
++++ b/parsers/Makefile
+@@ -1,6 +1,6 @@
+ all:
+-      $(CC) -g -Wall -c -I../ binary.c hex.c
++      $(CC) $(CFLAGS) -Wall -c -I../ binary.c hex.c
+       $(AR) r parsers.a        binary.o hex.o
+ clean: