Update ssltunnel to 1.16 (#3655)
authorFlorian Fainelli <florian@openwrt.org>
Sun, 6 Jul 2008 11:21:30 +0000 (11:21 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Sun, 6 Jul 2008 11:21:30 +0000 (11:21 +0000)
SVN-Revision: 11684

net/ssltunnel/Makefile

index 6146cd0a29fd77b7fef9627d9b5aab5f0d46917c..bafc854030abf1ec1e3db6e6421d3b5c37cc4ad7 100644 (file)
@@ -9,15 +9,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=ssltunnel
-PKG_VERSION:=1.15
+PKG_VERSION:=1.16
 PKG_RELEASE:=1
 
 PKG_SOURCE:=${PKG_NAME}-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://www.hsc.fr/ressources/outils/ssltunnel/download
-PKG_MD5SUM:=bfe529edb9b6c97bc03d213676b1f35d
-
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+PKG_MD5SUM:=4039b50566a33a4077883ea974e476d5
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -25,11 +22,20 @@ define Package/ssltunnel
   SECTION:=net
   CATEGORY:=Network
   DEPENDS:=+ppp +libopenssl
-  TITLE:=A PPP over SSL vpn tool
+  TITLE:=A PPP over SSL VPN tool
   URL:=http://www.hsc.fr/ressources/outils/ssltunnel/index.html
   SUBMENU:=VPN
 endef
 
+define Package/ssltunnel/description
+       SSLTunnel is a client/server program to create a PPP connection over a
+       SSL/TLS session.
+       Client and server are mutually authenticated using a X509 certificate,
+       PPP packets are then encrypted/decrypted realtime on each side.
+       It's possible to use ssltunnel to connect a machine to another, a
+       machine with a network or two networks sets.
+endef
+
 define Build/Configure
        $(call Build/Configure/Default, \
                , \