[packages] add sslsniff (thanks to David Cooper)
authorNicolas Thill <nico@openwrt.org>
Mon, 23 Feb 2009 18:07:00 +0000 (18:07 +0000)
committerNicolas Thill <nico@openwrt.org>
Mon, 23 Feb 2009 18:07:00 +0000 (18:07 +0000)
SVN-Revision: 14642

net/sslsniff/Makefile [new file with mode: 0644]
net/sslsniff/patches/01-cross-compile.patch [new file with mode: 0644]

diff --git a/net/sslsniff/Makefile b/net/sslsniff/Makefile
new file mode 100644 (file)
index 0000000..172579d
--- /dev/null
@@ -0,0 +1,52 @@
+# 
+# Copyright (C) 2009 David Cooper <dave@kupesoft.com>
+# Copyright (C) 2009 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+# $Id$
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=sslsniff
+PKG_VERSION:=0.5
+PKG_RELEASE:=1
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tgz
+PKG_SOURCE_URL:=http://www.thoughtcrime.org/software/sslsniff
+PKG_MD5SUM:=24653e2c4f1ca94328520667eb756369
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/sslsniff
+  SECTION:=net
+  CATEGORY:=Network
+  TITLE:=SSL man-in-the-middle attack
+  URL:=http://www.thoughtcrime.org/software/sslsniff/index.html
+  DEPENDS:=+libopenssl
+endef
+
+define Package/sslsniff/description
+ sslsniff is designed to MITM all SSL connections on a LAN,
+ and dynamically generates certs for the domains that are
+ being accessed on the fly. The new certificates are constructed
+ in a certificate chain that is signed by any certificate that
+ you provide.
+endef
+
+# Take this opportunity to remove the pre-packaged x86 binary
+define Build/Prepare
+$(call Build/Prepare/Default)
+       $(RM) $(PKG_BUILD_DIR)/sslsniff
+endef
+
+MAKE_FLAGS += CFLAGS="$(TARGET_CFLAGS) $(TARGET_CPPFLAGS) $(TARGET_LDFLAGS)"
+
+define Package/sslsniff/install
+       $(INSTALL_DIR) $(1)/usr/bin
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/sslsniff $(1)/usr/bin/
+endef
+
+$(eval $(call BuildPackage,sslsniff))
+
diff --git a/net/sslsniff/patches/01-cross-compile.patch b/net/sslsniff/patches/01-cross-compile.patch
new file mode 100644 (file)
index 0000000..48bee83
--- /dev/null
@@ -0,0 +1,24 @@
+diff -ruN sslsniff-0.5.orig/Makefile sslsniff-0.5/Makefile
+--- sslsniff-0.5.orig/Makefile 2009-02-16 12:00:36.000000000 -0500
++++ sslsniff-0.5/Makefile      2009-02-23 11:14:22.000000000 -0500
+@@ -1,4 +1,7 @@
++CC := gcc
++CFLAGS := -g -Wall
++
+ all:
+-      gcc -g -Wall -o sslsniff cache.c sslsniff.c network.c mx509.c mssl.c log.c -lcrypto -lssl
++      $(CC) $(CFLAGS) -o sslsniff cache.c sslsniff.c network.c mx509.c mssl.c log.c -lcrypto -lssl
+ clean:
+       rm sslsniff
+\ No newline at end of file
+diff -ruN sslsniff-0.5.orig/network.c sslsniff-0.5/network.c
+--- sslsniff-0.5.orig/network.c        2009-02-16 12:00:36.000000000 -0500
++++ sslsniff-0.5/network.c     2009-02-23 10:45:37.000000000 -0500
+@@ -27,6 +27,7 @@
+  * SUCH DAMAGE.
+  */
++#include <limits.h>
+ #include <stdio.h>
+ #include <stdlib.h>
+ #include <unistd.h>