ps3-utils: Add Build/InstallDev section to package makefile
authorGeoff Levand <geoffrey.levand@am.sony.com>
Tue, 18 Aug 2009 21:51:08 +0000 (21:51 +0000)
committerGeoff Levand <geoffrey.levand@am.sony.com>
Tue, 18 Aug 2009 21:51:08 +0000 (21:51 +0000)
Signed-off-by: Geoff Levand <geoffrey.levand@am.sony.com>
SVN-Revision: 17302

package/ps3-utils/Makefile

index 66a93b8ba70af70c410b17b63bb0b19cdb8de749..c18aec871d6faeac55ea868896bd97eb719bc6a8 100644 (file)
@@ -41,6 +41,18 @@ define Build/Configure
        $(call Build/Configure/Default)
 endef
 
+define Build/InstallDev
+       $(INSTALL_DIR) $(1)/usr/include
+       $(INSTALL_DATA) \
+               $(PKG_INSTALL_DIR)/usr/include/ps3*.h \
+               $(1)/usr/include
+
+       $(INSTALL_DIR) $(1)/usr/lib
+       $(INSTALL_BIN) \
+               $(PKG_INSTALL_DIR)/usr/lib/libps3-utils.{la,a,so*} \
+               $(1)/usr/lib/
+endef
+
 define Package/ps3-utils/install
        $(INSTALL_DIR) $(1)/usr/sbin
        $(INSTALL_DIR) $(1)/usr/bin