[s3c24xx] Update to 2.6.30.1, refresh patches
authorLars-Peter Clausen <lars@metafoo.de>
Sun, 5 Jul 2009 09:47:42 +0000 (09:47 +0000)
committerLars-Peter Clausen <lars@metafoo.de>
Sun, 5 Jul 2009 09:47:42 +0000 (09:47 +0000)
SVN-Revision: 16680

target/linux/s3c24xx/Makefile
target/linux/s3c24xx/patches-2.6.30/010-s3c-dma.patch
target/linux/s3c24xx/patches-2.6.30/110-serial.patch
target/linux/s3c24xx/patches-2.6.30/120-fix-wm8753-reg_cache.patch

index 33050cbbc600f0fd738f45a2e86a0ef7ef9a0d0d..c4303e3aa816e522f388c7a6381c9ce67b39b7f4 100644 (file)
@@ -12,7 +12,7 @@ BOARDNAME:=Samsung S3C24xx
 FEATURES:=jffs2
 CFLAGS:=-O2 -pipe -march=armv4t -mtune=arm920t -funit-at-a-time
 
-LINUX_VERSION:=2.6.29
+LINUX_VERSION:=2.6.30.1
 
 DEVICE_TYPE=phone
 
index 871514a6e6697f2b5aabaef9eabbbf1d0b39c5eb..e0ff7c442c9bd11c2a6f7cf880aaebea79adbcd2 100644 (file)
  #include <mach/regs-mem.h>
  #include <mach/regs-lcd.h>
  #include <mach/regs-sdi.h>
---- a/sound/soc/s3c24xx/s3c24xx-pcm.c  2009-06-10 05:05:27.000000000 +0200
-+++ b/sound/soc/s3c24xx/s3c24xx-pcm.c  2009-05-16 13:25:48.000000000 +0200
-@@ -218,23 +231,16 @@
+--- a/sound/soc/s3c24xx/s3c24xx-pcm.c
++++ b/sound/soc/s3c24xx/s3c24xx-pcm.c
+@@ -218,24 +218,17 @@ static int s3c24xx_pcm_prepare(struct sn
         * sync to pclk, half-word transfers to the IIS-FIFO. */
        if (substream->stream == SNDRV_PCM_STREAM_PLAYBACK) {
                s3c2410_dma_devconfig(prtd->params->channel,
 +                                    S3C2410_DMASRC_HW,
 +                                    prtd->params->dma_addr);
        }
-+
 +      s3c2410_dma_config(prtd->params->channel,
 +                         prtd->params->dma_size);
++
        /* flush the DMA channel */
        s3c2410_dma_ctrl(prtd->params->channel, S3C2410_DMAOP_FLUSH);
+       prtd->dma_loaded = 0;
index edb3aa5ac5e84618f18cd493c359dde576e445c1..e01394b6ffb8b3f45ffe8590d46f605eb77a1505 100644 (file)
@@ -1,7 +1,6 @@
-diff -urNX /opt/Projects/openmoko-linux-2.6/orig/dontdiff /opt/Projects/openmoko-linux-2.6/orig/linux-2.6.29-rc3/drivers/serial/samsung.c /opt/Projects/openmoko-linux-2.6/drivers/serial/samsung.c
---- a/drivers/serial/samsung.c 2009-01-28 19:49:30.000000000 +0100
-+++ b/drivers/serial/samsung.c 2009-05-16 13:25:47.000000000 +0200
-@@ -1208,6 +1355,13 @@
+--- a/drivers/serial/samsung.c
++++ b/drivers/serial/samsung.c
+@@ -1263,6 +1263,13 @@ module_exit(s3c24xx_serial_modexit);
  #ifdef CONFIG_SERIAL_SAMSUNG_CONSOLE
  
  static struct uart_port *cons_uart;
@@ -15,7 +14,7 @@ diff -urNX /opt/Projects/openmoko-linux-2.6/orig/dontdiff /opt/Projects/openmoko
  
  static int
  s3c24xx_serial_console_txrdy(struct uart_port *port, unsigned int ufcon)
-@@ -1232,9 +1386,21 @@
+@@ -1287,9 +1294,21 @@ static void
  s3c24xx_serial_console_putchar(struct uart_port *port, int ch)
  {
        unsigned int ufcon = rd_regl(cons_uart, S3C2410_UFCON);
@@ -37,4 +36,3 @@ diff -urNX /opt/Projects/openmoko-linux-2.6/orig/dontdiff /opt/Projects/openmoko
  }
  
  static void
-
index c1c4a93ed26a72e82e18ee2077a0a9c514321644..f7e801ce96383b69567433fc2ec8a6f705845026 100644 (file)
@@ -1,6 +1,6 @@
---- a/sound/soc/codecs/wm8753.c        2009-06-28 20:58:43.000000000 +0200
-+++ b/sound/soc/codecs/wm8753.c        2009-06-28 21:24:59.000000000 +0200
-@@ -79,7 +79,7 @@
+--- a/sound/soc/codecs/wm8753.c
++++ b/sound/soc/codecs/wm8753.c
+@@ -79,7 +79,7 @@ static const u16 wm8753_reg[] = {
        0x0097, 0x0097, 0x0000, 0x0004,
        0x0000, 0x0083, 0x0024, 0x01ba,
        0x0000, 0x0083, 0x0024, 0x01ba,
@@ -9,7 +9,7 @@
  };
  
  /* codec private data */
-@@ -1660,11 +1660,11 @@
+@@ -1660,11 +1660,11 @@ static int wm8753_register(struct wm8753
        codec->set_bias_level = wm8753_set_bias_level;
        codec->dai = wm8753_dai;
        codec->num_dai = 2;