Fix subversion compilation when apache is present on the host system (#1737)
authorFlorian Fainelli <florian@openwrt.org>
Tue, 22 May 2007 10:28:20 +0000 (10:28 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Tue, 22 May 2007 10:28:20 +0000 (10:28 +0000)
SVN-Revision: 7305

net/subversion/Makefile

index 49606bc79dc2eaec49a0d75771180550edf1818f..10aa657417b573b42b1bcbb70d142a53a078ffcf 100644 (file)
@@ -26,7 +26,7 @@ define Package/subversion/Default
   SECTION:=net
   CATEGORY:=Network
   TITLE:=A compelling replacement for CVS
-  DEPENDS:=+zlib +neon +libintl
+  DEPENDS:=+zlib +neon +libintl +apr +apr-util
   URL:=http://subversion.tigris.org/
   SUBMENU:=subversion
 endef
@@ -61,6 +61,8 @@ define Build/Configure
                --without-berkeley-db \
                --with-ssl \
                --disable-neon-version-check \
+               --with-apxs=no \
+               --with-apache=no \
                , \
                svn_lib_neon=yes \
                LDFLAGS="-lcrypt -lnsl -lm -lintl -L$(STAGING_DIR)/usr/lib/libintl/lib/ \
@@ -96,3 +98,7 @@ endef
 $(eval $(call BuildPackage,subversion-libs))
 $(eval $(call BuildPackage,subversion-client))
 $(eval $(call BuildPackage,subversion-server))
+
+$(eval $(call RequireCommand,/usr/bin/ruby, \
+       $(PKG_NAME) requires ruby installed on the host-system. \
+))