override AM_CFLAGS holding conflicting optimization flag, remove unneeded --with...
authorNicolas Thill <nico@openwrt.org>
Fri, 27 Oct 2006 19:32:58 +0000 (19:32 +0000)
committerNicolas Thill <nico@openwrt.org>
Fri, 27 Oct 2006 19:32:58 +0000 (19:32 +0000)
SVN-Revision: 5315

libs/alsa-lib/Makefile

index f8294f6a88ec7d5a1bb616684a6a8d2ae448a276..27ebe81624e153fa48fae169d0f5fe19b5adc1a2 100644 (file)
@@ -35,9 +35,8 @@ endef
 
 define Build/Configure
        $(call Build/Configure/Default,\
 
 define Build/Configure
        $(call Build/Configure/Default,\
-               --enable-shared=yes \
-               --enable-static=yes \
-               --with-gnu-ld \
+               --enable-shared \
+               --enable-static \
                --disable-debugging \
                --disable-profiling \
                --with-softfloat \
                --disable-debugging \
                --disable-profiling \
                --with-softfloat \
@@ -46,7 +45,9 @@ define Build/Configure
 endef
 
 define Build/Compile
 endef
 
 define Build/Compile
+       # override AM_CFLAGS holding inappropriate optimization flags
        $(MAKE) -C $(PKG_BUILD_DIR) \
        $(MAKE) -C $(PKG_BUILD_DIR) \
+               AM_CFLAGS="" \
                DESTDIR="$(PKG_INSTALL_DIR)" \
                all install
 endef
                DESTDIR="$(PKG_INSTALL_DIR)" \
                all install
 endef