Add wput package
authorNicolas Thill <nico@openwrt.org>
Sat, 21 May 2005 02:15:53 +0000 (02:15 +0000)
committerNicolas Thill <nico@openwrt.org>
Sat, 21 May 2005 02:15:53 +0000 (02:15 +0000)
SVN-Revision: 1004

openwrt/package/Config.in
openwrt/package/Makefile
openwrt/package/wput/Config.in [new file with mode: 0644]
openwrt/package/wput/Makefile [new file with mode: 0644]
openwrt/package/wput/ipkg/wput.control [new file with mode: 0644]

index 79c4516f792396111a952a1acd7fc679e521edb6..63baf6887dee925d75fa35dc2e258517e8872889 100644 (file)
@@ -72,6 +72,7 @@ source "package/ulogd/Config.in"
 source "package/vsftpd/Config.in"
 source "package/wireless-tools/Config.in"
 source "package/wol/Config.in"
+source "package/wput/Config.in"
 source "package/xinetd/Config.in"
 
 comment "Libraries"
index 59119ef68fccf2ace26a0f19de2865cd2e8754a8..c5a3c07096e80e78ad1d1e1d9e38f0ab29249325 100644 (file)
@@ -94,6 +94,7 @@ package-$(BR2_PACKAGE_USBUTILS) += usbutils
 package-$(BR2_PACKAGE_VSFTPD) += vsftpd
 package-$(BR2_PACKAGE_WIRELESS_TOOLS) += wireless-tools
 package-$(BR2_PACKAGE_WOL) += wol
+package-$(BR2_PACKAGE_WPUT) += wput
 package-$(BR2_PACKAGE_XINETD) += xinetd
 package-$(BR2_PACKAGE_ZLIB) += zlib
 
diff --git a/openwrt/package/wput/Config.in b/openwrt/package/wput/Config.in
new file mode 100644 (file)
index 0000000..8aa5ba3
--- /dev/null
@@ -0,0 +1,9 @@
+config BR2_PACKAGE_WPUT
+       tristate "wput - A wget-like command-line FTP client"
+       default m if CONFIG_DEVEL
+       help
+         A wget-like command-line FTP client.
+         
+         http://itooktheredpill.dyndns.org/wput/
+         
+
diff --git a/openwrt/package/wput/Makefile b/openwrt/package/wput/Makefile
new file mode 100644 (file)
index 0000000..bbe8343
--- /dev/null
@@ -0,0 +1,60 @@
+# $Id$
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=wput
+PKG_VERSION:=0.5
+PKG_RELEASE:=1
+PKG_MD5SUM:=441b2e07219f78167b29a7ac33488fff
+
+PKG_SOURCE_URL:=http://itooktheredpill.dyndns.org/wput/
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tgz
+PKG_CAT:=zcat
+
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)
+PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+
+include $(TOPDIR)/package/rules.mk
+
+$(eval $(call PKG_template,WPUT,wput,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
+
+$(PKG_BUILD_DIR)/.configured:
+       (cd $(PKG_BUILD_DIR); rm -rf config.{cache,status} ; \
+               $(TARGET_CONFIGURE_OPTS) \
+               CFLAGS="$(TARGET_CFLAGS)" \
+               ./configure \
+                 --target=$(GNU_TARGET_NAME) \
+                 --host=$(GNU_TARGET_NAME) \
+                 --build=$(GNU_HOST_NAME) \
+                 --program-prefix="" \
+                 --program-suffix="" \
+                 --prefix=/usr \
+                 --exec-prefix=/usr \
+                 --bindir=/usr/bin \
+                 --datadir=/usr/share \
+                 --includedir=/usr/include \
+                 --infodir=/usr/share/info \
+                 --libdir=/usr/lib \
+                 --libexecdir=/usr/lib \
+                 --localstatedir=/var \
+                 --mandir=/usr/share/man \
+                 --sbindir=/usr/sbin \
+                 --sysconfdir=/etc \
+                 $(DISABLE_LARGEFILE) \
+                 $(DISABLE_NLS) \
+                 --enable-shared \
+                 --disable-static \
+                 --disable-g-switch \
+       )
+       touch $@
+
+$(PKG_BUILD_DIR)/.built:
+       $(MAKE) -C $(PKG_BUILD_DIR)
+       touch $@
+
+$(IPKG_WPUT):
+       install -d -m0755 $(IDIR_WPUT)/usr/bin
+       install -m0755 $(PKG_BUILD_DIR)/wput $(IDIR_WPUT)/usr/bin/
+       $(RSTRIP) $(IDIR_WPUT)
+       $(IPKG_BUILD) $(IDIR_WPUT) $(PACKAGE_DIR)
+
diff --git a/openwrt/package/wput/ipkg/wput.control b/openwrt/package/wput/ipkg/wput.control
new file mode 100644 (file)
index 0000000..80d6bae
--- /dev/null
@@ -0,0 +1,8 @@
+Package: wput
+Priority: optional
+Section: net
+Version: [TBDL]
+Architecture: [TBDL]
+Maintainer: Nico <nthill@free.fr>
+Source: http://nthill.free.fr/openwrt/sources/wput/
+Description: a wget-like command-line FTP client