[packages] boost: fix compile failure (#10535, thanks zhenglei), refresh patches
authorStephen Walker <stephendwalker@gmail.com>
Mon, 23 Jan 2012 12:31:38 +0000 (12:31 +0000)
committerStephen Walker <stephendwalker@gmail.com>
Mon, 23 Jan 2012 12:31:38 +0000 (12:31 +0000)
SVN-Revision: 29873

libs/boost/Makefile
libs/boost/patches/100-do-not-use-librt.patch

index af0bbc3075c4bb894367dce0eee92ff4dd6be030..d9c5e27137e5f36a49ea8cb398902523af7869a5 100644 (file)
@@ -149,7 +149,7 @@ TARGET_LDFLAGS += -pthreads -lrt
 
 define Build/Compile
        ( cd $(PKG_BUILD_DIR) ; \
-               echo "using gcc : : $(GNU_TARGET_NAME)-gcc : <cflags>$(TARGET_CFLAGS) <cxxflags>$(TARGET_CXXFLAGS) <linkflags>$(TARGET_LDFLAGS) ;" > tools/build/v2/site-config.jam ; \
+               echo "using gcc : : $(GNU_TARGET_NAME)-gcc : <compileflags>\"$(TARGET_CFLAGS)\" <cxxflags>\"$(TARGET_CXXFLAGS)\" <linkflags>\"$(TARGET_LDFLAGS)\" ;" > tools/build/v2/site-config.jam ; \
                $(if $(CONFIG_PACKAGE_boost-python), \
                        echo "using python : : $(STAGING_DIR_ROOT)/usr/bin/python :     $(STAGING_DIR)/usr/include/python2.6/ ;" >> \
                                tools/build/v2/site-config.jam; \
index 7f1d4f6ff32d43c81a1092bc8107541a59fe00e1..b8e62a56cad8776747df270e49cfdd06f374e863 100644 (file)
@@ -1,7 +1,6 @@
-diff -ruN boost_1_48_0.orig/tools/build/v2/tools/gcc.jam boost_1_48_0/tools/build/v2/tools/gcc.jam
---- boost_1_48_0.orig/tools/build/v2/tools/gcc.jam     2011-06-06 22:36:21.000000000 +0200
-+++ boost_1_48_0/tools/build/v2/tools/gcc.jam  2011-11-16 13:15:49.071254804 +0100
-@@ -1063,8 +1063,7 @@
+--- a/tools/build/v2/tools/gcc.jam
++++ b/tools/build/v2/tools/gcc.jam
+@@ -1018,8 +1018,7 @@ rule setup-threading ( targets * : sourc
              }
              case * :
              {
@@ -11,10 +10,9 @@ diff -ruN boost_1_48_0.orig/tools/build/v2/tools/gcc.jam boost_1_48_0/tools/buil
              }
          }
      
-diff -ruN boost_1_48_0.orig/tools/build/v2/tools/gcc.py boost_1_48_0/tools/build/v2/tools/gcc.py
---- boost_1_48_0.orig/tools/build/v2/tools/gcc.py      2011-01-25 19:06:12.000000000 +0100
-+++ boost_1_48_0/tools/build/v2/tools/gcc.py   2011-11-16 13:16:12.601254423 +0100
-@@ -685,8 +685,8 @@
+--- a/tools/build/v2/tools/gcc.py
++++ b/tools/build/v2/tools/gcc.py
+@@ -685,8 +685,8 @@ elif bjam.variable('UNIX'):
          # Darwin has no threading options, don't set anything here.
          pass
      else: