Add some mirrors
authorNicolas Thill <nico@openwrt.org>
Sun, 5 Jun 2005 17:41:32 +0000 (17:41 +0000)
committerNicolas Thill <nico@openwrt.org>
Sun, 5 Jun 2005 17:41:32 +0000 (17:41 +0000)
SVN-Revision: 1156

openwrt/package/gmp/Makefile
openwrt/package/libosip2/Makefile
openwrt/package/screen/Makefile
openwrt/package/tcpdump/Makefile
openwrt/package/tor/Makefile

index 3a002294f3bbc611cbd425db33a49acff19ad8b7..4cd0310e46ff6dc49b15a7389d1c4a5bf30c3e28 100644 (file)
@@ -7,7 +7,10 @@ PKG_VERSION:=4.1.4
 PKG_RELEASE:=1
 PKG_MD5SUM:=0aa7d3b3f5b5ec5951e7dddd6f65e891
 
-PKG_SOURCE_URL:=ftp://ftp.gnu.org/gnu/gmp/
+PKG_SOURCE_URL:=ftp://ftp.gnu.org/gnu/gmp/ \
+       ftp://ftp.belnet.be/mirror/ftp.gnu.org/gnu/gmp/ \
+       ftp://ftp.mirror.nl/pub/mirror/gnu/gmp/ \
+       http://mirror.switch.ch/ftp/mirror/gnu/gmp/
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_CAT:=bzcat
 
@@ -57,22 +60,23 @@ $(PKG_BUILD_DIR)/.built: $(PKG_BUILD_DIR)/.configured
 
 $(IPKG_LIBGMP):
        install -m0755 -d $(IDIR_LIBGMP)/usr/lib
-       cp -fpR $(PKG_INSTALL_DIR)/usr/lib/libgmp.so.* $(IDIR_LIBGMP)/usr/lib/
+       cp -fp $(PKG_INSTALL_DIR)/usr/lib/libgmp.so.* $(IDIR_LIBGMP)/usr/lib/
        $(RSTRIP) $(IDIR_LIBGMP)
        $(IPKG_BUILD) $(IDIR_LIBGMP) $(PACKAGE_DIR)
 
 $(STAGING_DIR)/usr/lib/libgmp.so: $(PKG_BUILD_DIR)/.built
        mkdir -p $(STAGING_DIR)/usr/include
-       cp -fpR $(PKG_INSTALL_DIR)/usr/include/gmp* $(STAGING_DIR)/usr/include/
+       cp -fp $(PKG_INSTALL_DIR)/usr/include/gmp* $(STAGING_DIR)/usr/include/
        mkdir -p $(I_LIBPCAP_DEV)/usr/lib
-       cp -fpR $(PKG_INSTALL_DIR)/usr/lib/libgmp.{a,so*} $(STAGING_DIR)/usr/lib/
-       touch $(STAGING_DIR)/usr/lib/libgmp.so
+       cp -fp $(PKG_INSTALL_DIR)/usr/lib/libgmp.{a,so*} $(STAGING_DIR)/usr/lib/
+       touch $@
 
 install-dev: $(STAGING_DIR)/usr/lib/libgmp.so
 
 uninstall-dev:
-       rm -rf $(STAGING_DIR)/usr/include/gmp*
-       rm -rf $(STAGING_DIR)/usr/lib/libgmp.{a,so*}
+       rm -rf \
+               $(STAGING_DIR)/usr/include/gmp* \
+               $(STAGING_DIR)/usr/lib/libgmp.{a,so*} \
 
 compile: install-dev
 clean: uninstall-dev
index c0b0357677459e917c916be7f13baea229b926db..d7a504ae12b6f8c7b858c6d8476de271336d34b5 100644 (file)
@@ -7,7 +7,10 @@ PKG_VERSION:=2.0.9
 PKG_RELEASE:=1
 PKG_MD5SUM:=dba6d47332f4842f70694792939fec2d
 
-PKG_SOURCE_URL:=http://ftp.gnu.org/gnu/osip/
+PKG_SOURCE_URL:=http://ftp.gnu.org/gnu/osip/ \
+       ftp://ftp.belnet.be/mirror/ftp.gnu.org/gnu/osip/ \
+       ftp://ftp.mirror.nl/pub/mirror/gnu/osip/ \
+       http://mirror.switch.ch/ftp/mirror/gnu/osip/
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_CAT:=zcat
 
@@ -18,7 +21,7 @@ include $(TOPDIR)/package/rules.mk
 
 $(eval $(call PKG_template,LIBOSIP2,libosip2,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
 
-$(PKG_BUILD_DIR)/.configured: $(PKG_BUILD_DIR)/.prepared
+$(PKG_BUILD_DIR)/.configured:
        (cd $(PKG_BUILD_DIR); rm -rf config.{cache,status} ; \
                $(TARGET_CONFIGURE_OPTS) \
                CFLAGS="$(strip $(TARGET_CFLAGS))" \
@@ -55,7 +58,7 @@ $(PKG_BUILD_DIR)/.configured: $(PKG_BUILD_DIR)/.prepared
        );
        touch $@
 
-$(PKG_BUILD_DIR)/.built: $(PKG_BUILD_DIR)/.configured
+$(PKG_BUILD_DIR)/.built:
        rm -rf $(PKG_INSTALL_DIR)
        mkdir -p $(PKG_INSTALL_DIR)
        $(MAKE) -C $(PKG_BUILD_DIR) \
@@ -73,14 +76,15 @@ $(STAGING_DIR)/usr/lib/libosip2.so: $(PKG_BUILD_DIR)/.built
        mkdir -p $(STAGING_DIR)/usr/include
        cp -fpR $(PKG_INSTALL_DIR)/usr/include/osip{,parser}2 $(STAGING_DIR)/usr/include/
        mkdir -p $(STAGING_DIR)/usr/lib
-       cp -fpR $(PKG_INSTALL_DIR)/usr/lib/libosip{,parser}2.{a,so*} $(STAGING_DIR)/usr/lib/
-       touch $(STAGING_DIR)/usr/lib/libosip2.so
+       cp -fp $(PKG_INSTALL_DIR)/usr/lib/libosip{,parser}2.{a,so*} $(STAGING_DIR)/usr/lib/
+       touch $@
 
 install-dev: $(STAGING_DIR)/usr/lib/libosip2.so
 
 uninstall-dev:
-       rm -rf $(STAGING_DIR)/usr/include/osip{,parser}2
-       rm -rf $(STAGING_DIR)/usr/lib/libosip{,parser}2.{a,so*}
+       rm -rf \
+               $(STAGING_DIR)/usr/include/osip{,parser}2 \
+               $(STAGING_DIR)/usr/lib/libosip{,parser}2.{a,so*} \
 
 compile: install-dev
 clean: uninstall-dev
index eaaa9abbe77da020e375aaa086b4a9e42e5453f4..c4223c4288abc419e2d0569e209394f47d06b4e6 100644 (file)
@@ -7,7 +7,10 @@ PKG_VERSION:=4.0.2
 PKG_RELEASE:=1
 PKG_MD5SUM:=ed68ea9b43d9fba0972cb017a24940a1
 
-PKG_SOURCE_URL:=http://ftp.gnu.org/gnu/screen
+PKG_SOURCE_URL:=http://ftp.gnu.org/gnu/screen \
+       ftp://ftp.belnet.be/mirror/ftp.gnu.org/gnu/screen/ \
+       ftp://ftp.mirror.nl/pub/mirror/gnu/screen/ \
+       http://mirror.switch.ch/ftp/mirror/gnu/screen/
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_CAT:=zcat
 
index 1b1641e0448ff4b60a783be1fc21e5657120a31a..ec8690807fd6f6503657d6ed40cf72bd91a12b54 100644 (file)
@@ -7,7 +7,10 @@ PKG_VERSION:=3.8.3
 PKG_RELEASE:=1
 PKG_MD5SUM:=30645001f4b97019677cad88d3811904
 
-PKG_SOURCE_URL:=http://www.tcpdump.org/release/
+PKG_SOURCE_URL:=http://www.tcpdump.org/release/ \
+       http://ftp.gwdg.de/pub/misc/tcpdump/ \
+       http://www.at.tcpdump.org/ \
+       http://www.br.tcpdump.org/
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_CAT:=zcat
 
index e037da533d6c998accedd05f6d570e8dd81a4ce3..078517b2660cbfe57da3c08e82902a7032177b3b 100644 (file)
@@ -8,7 +8,9 @@ PKG_RELEASE:=1
 PKG_UPSTREAM_VERSION=0.1.0.8-rc
 PKG_MD5SUM:=22f5c162e1c09f8693a21826f6a9999f
 
-PKG_SOURCE_URL:=http://tor.eff.org/dist/
+PKG_SOURCE_URL:=http://tor.eff.org/dist/ \
+       http://ftp.se.linux.org/crypto/tor/ \
+       http://tor.meulie.net/
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_UPSTREAM_VERSION).tar.gz
 PKG_CAT:=zcat