bonnie++: pass TARGET_CXXFLAGS correctly
authorFlorian Fainelli <florian@openwrt.org>
Sat, 8 Mar 2014 00:56:32 +0000 (00:56 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Sat, 8 Mar 2014 00:56:32 +0000 (00:56 +0000)
bonnie++ was not compiled using the TARGET_CXXFLAGS we passed, which will result
in build failures on e.g: ARM VFP toolchains, fix that.

Signed-off-by: Florian Fainelli <florian@openwrt.org>
SVN-Revision: 39798

utils/bonnie++/Makefile

index bb7711361c00d1111a657e171981bce1b7db31a5..55fe123b93656e292f891511c3fa93e893783fdd 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2009 OpenWrt.org
+# Copyright (C) 2009-2014 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=bonnie++
 PKG_VERSION:=1.96
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tgz
 PKG_SOURCE_URL:=http://www.coker.com.au/bonnie++/experimental/
@@ -36,6 +36,7 @@ define Build/Compile
        $(MAKE) -C $(PKG_BUILD_DIR) \
                TARGET_CXX="$(TARGET_CXX)" \
                TARGET_LINK="$(TARGET_CXX)" \
+               MORECFLAGS="$(TARGET_CPPFLAGS) $(TARGET_CXXFLAGS)" \
                DESTDIR="$(PKG_INSTALL_DIR)" \
                all
 endef