The attached patch includes /usr/share/postgresql/snowball_create.sql in
authorTravis Kemen <thepeople@openwrt.org>
Thu, 15 May 2008 03:13:03 +0000 (03:13 +0000)
committerTravis Kemen <thepeople@openwrt.org>
Thu, 15 May 2008 03:13:03 +0000 (03:13 +0000)
the pgsql-server package.  This is needed by initdb to actually create a
new database. Signed-off-by: Jeremy Jones <jjones <at> pavlovmedia.com>

SVN-Revision: 11141

libs/postgresql/Makefile

index 5d60831e7ba38600f677e025d362859451607a3a..c31a8b11325b68e20fe83d4fad0d87abcc055534 100644 (file)
@@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=postgresql
 PKG_VERSION:=8.3.0
 
 PKG_NAME:=postgresql
 PKG_VERSION:=8.3.0
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
@@ -223,6 +223,7 @@ define Package/pgsql-server/install
                $(PKG_INSTALL_DIR)/usr/share/postgresql/psqlrc.sample \
                $(PKG_INSTALL_DIR)/usr/share/postgresql/recovery.conf.sample \
                $(PKG_INSTALL_DIR)/usr/share/postgresql/system_views.sql \
                $(PKG_INSTALL_DIR)/usr/share/postgresql/psqlrc.sample \
                $(PKG_INSTALL_DIR)/usr/share/postgresql/recovery.conf.sample \
                $(PKG_INSTALL_DIR)/usr/share/postgresql/system_views.sql \
+               $(PKG_INSTALL_DIR)/usr/share/postgresql/snowball_create.sql \
                $(1)/usr/share/postgresql
 
                $(INSTALL_DATA) ./files/postgresql.config $(1)/etc/config/postgresql
                $(1)/usr/share/postgresql
 
                $(INSTALL_DATA) ./files/postgresql.config $(1)/etc/config/postgresql