[packages] mercurial: update to 1.8.4, refresh patches
authorStephen Walker <stephendwalker@gmail.com>
Tue, 7 Jun 2011 01:42:39 +0000 (01:42 +0000)
committerStephen Walker <stephendwalker@gmail.com>
Tue, 7 Jun 2011 01:42:39 +0000 (01:42 +0000)
SVN-Revision: 27120

net/mercurial/Makefile
net/mercurial/patches/001-no_bzip2.patch

index 00c84ab3b3029ab3a546fb793dc66050fb2951b9..a94b7583cd0436ea54b01ec9fa925fd608e75ceb 100644 (file)
@@ -8,12 +8,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=mercurial
-PKG_VERSION:=1.8
+PKG_VERSION:=1.8.4
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://mercurial.selenic.com/release
-PKG_MD5SUM:=c97b39832f2da60f951d1b7701688bd2
+PKG_MD5SUM:=b3dcc3de473e003dd1cc0500dcd9de47
 
 PKG_BUILD_DEPENDS:=python-mini
 
index e7ead417b955a630236c90754a84ac76d693fc8f..d43accadec295e1f09e3b9fba4d3c94dc075105f 100644 (file)
                      archives.append({"type" : i[0], "extension": i[1],
 --- a/mercurial/hgweb/hgweb_mod.py
 +++ b/mercurial/hgweb/hgweb_mod.py
-@@ -39,7 +39,7 @@ class hgweb(object):
-         hook.redirect(True)
+@@ -40,7 +40,7 @@ class hgweb(object):
          self.mtime = -1
+         self.size = -1
          self.reponame = name
 -        self.archives = 'zip', 'gz', 'bz2'
 +        self.archives = 'zip', 'gz'
          self.stripecount = 1
          # a repo owner may set web.templates in .hg/hgrc to get any file
          # readable by the user running the CGI script
-@@ -280,7 +280,6 @@ class hgweb(object):
+@@ -284,7 +284,6 @@ class hgweb(object):
                  yield {"type" : i, "extension" : spec[2], "node" : nodeid}
  
      archive_specs = {
      bundletype = btypes.get(bundletype)
      if bundletype not in changegroup.bundletypes:
          raise util.Abort(_('unknown bundle type specified with --type'))
-@@ -4307,7 +4306,7 @@ table = {
+@@ -4316,7 +4315,7 @@ table = {
             _('a base changeset assumed to be available at the destination'),
             _('REV')),
            ('a', 'all', None, _('bundle all changesets in the repository')),