Update lftp to 3.7.7 (#4413)
authorFlorian Fainelli <florian@openwrt.org>
Sun, 4 Jan 2009 12:13:28 +0000 (12:13 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Sun, 4 Jan 2009 12:13:28 +0000 (12:13 +0000)
SVN-Revision: 13854

net/lftp/Makefile
net/lftp/patches/001-libintl.patch
net/lftp/patches/002-gettimeofday.patch [new file with mode: 0644]

index f29531cf427cd8eebfa531f6537999a7c162e914..ed81ce3a2b7d0fa662c1b55d54dd692c52024ee5 100644 (file)
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=lftp
-PKG_VERSION:=3.7.3
+PKG_VERSION:=3.7.7
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
-PKG_SOURCE_URL:=http://ftp.yars.free.net/pub/source/lftp/old/
-PKG_MD5SUM:=fc98506620b059d712341d624eb720d6
+PKG_SOURCE_URL:=http://ftp.yars.free.net/pub/source/lftp/
+PKG_MD5SUM:=7b1c58a6289448140b1cd328e1d51f94
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
 
@@ -44,7 +44,7 @@ CONFIGURE_VARS += \
         CXXFLAGS="$$$$CXXFLAGS -fno-builtin -I$(STAGING_DIR)/usr/include/uClibc++ -nostdinc++" \
         CPPFLAGS="$$$$CPPFLAGS -I$(STAGING_DIR)/usr/include/uClibc++" \
         LDFLAGS="$$$$LDFLAGS" \
-        LIBS="-nodefaultlibs -lz -lutil -luClibc++ -lcurses -lgcc_s -ldl" \
+        LIBS="-nodefaultlibs -lz -lutil -luClibc++ -lcurses -lgcc -lgcc_s -ldl" \
 
 define Build/Compile
         $(MAKE) -C $(PKG_BUILD_DIR) \
index ac890ac35264effb658d4fcd74b552977a829987..9891ca8501d485b347e9db363c39868b6dd69f65 100644 (file)
@@ -1,6 +1,6 @@
-diff -burN lftp-3.7.4.org/lib/gettext.h lftp-3.7.4/lib/gettext.h
---- lftp-3.7.4.org/lib/gettext.h       2008-05-18 07:58:27.000000000 +0200
-+++ lftp-3.7.4/lib/gettext.h   2008-11-05 16:03:37.769820993 +0100
+diff -burN lftp-3.7.7/lib/gettext.h lftp-3.7.7.patched/lib/gettext.h
+--- lftp-3.7.7/lib/gettext.h   2008-05-16 18:28:43.000000000 +0200
++++ lftp-3.7.7.patched/lib/gettext.h   2009-01-03 18:59:05.374184151 +0100
 @@ -22,7 +22,6 @@
  #if ENABLE_NLS
  
diff --git a/net/lftp/patches/002-gettimeofday.patch b/net/lftp/patches/002-gettimeofday.patch
new file mode 100644 (file)
index 0000000..ea6d490
--- /dev/null
@@ -0,0 +1,23 @@
+diff -burN lftp-3.7.7/lib/sys_time.in.h lftp-3.7.7.patched/lib/sys_time.in.h
+--- lftp-3.7.7/lib/sys_time.in.h       2008-10-24 16:00:33.000000000 +0200
++++ lftp-3.7.7.patched/lib/sys_time.in.h       2009-01-03 21:20:34.129104049 +0100
+@@ -39,6 +39,10 @@
+ #  include <time.h>
+ # endif
++#ifdef __cplusplus
++extern "C" {
++#endif 
++
+ # if ! @HAVE_STRUCT_TIMEVAL@
+ struct timeval
+ {
+@@ -53,4 +57,8 @@
+ int gettimeofday (struct timeval *restrict, void *restrict);
+ # endif
++#ifdef __cplusplus
++}
++#endif 
++
+ #endif /* _GL_SYS_TIME_H */