fix a small bug in the unpack code
authorFelix Fietkau <nbd@openwrt.org>
Fri, 16 Mar 2007 21:32:59 +0000 (21:32 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Fri, 16 Mar 2007 21:32:59 +0000 (21:32 +0000)
SVN-Revision: 6587

include/unpack.mk

index e195f316f6787fe9d3d025819319673b579e58b0..b8349c9ca46d13e9f4ecf7792f97d3a0f7e4d471 100644 (file)
@@ -42,7 +42,7 @@ ifeq ($(strip $(PKG_UNPACK)),)
   endif
  
   # compatibility code for packages that set PKG_CAT
-  ifeq ($(strip $(PKG_CAT)$(PKG_UNPACK)),)
+  ifeq ($(strip $(PKG_UNPACK)),)
     # use existing PKG_CAT
     PKG_UNPACK:=$(PKG_CAT) $(DL_DIR)/$(PKG_SOURCE) | $(TAR_CMD)
     ifeq ($(PKG_CAT),unzip)