st2205tool: Fix parallel build
authorMichael Büsch <mb@bu3sch.de>
Sat, 9 Oct 2010 15:12:08 +0000 (15:12 +0000)
committerMichael Büsch <mb@bu3sch.de>
Sat, 9 Oct 2010 15:12:08 +0000 (15:12 +0000)
SVN-Revision: 23360

libs/st2205tool/Makefile
libs/st2205tool/patches/100-base-makefile.patch

index 29ac98c3d13da6fbea4e667ff8e5ad5d9148f2ef..81e120f42128c651d4b3051a1b803eca4c362fc6 100644 (file)
@@ -16,6 +16,7 @@ PKG_SOURCE_URL:=http://downloads.openwrt.org/sources/
 PKG_MD5SUM:=827e3b719ebaf6bc537f2ce0ece3fccb
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)
+PKG_BUILD_PARALLEL:=1
 
 include $(INCLUDE_DIR)/package.mk
 
index 805887d77f99fa53ddb994f290b4f323bba1052b..854d040893c7d8042374b0c18a493ed6d51dcc81 100644 (file)
@@ -1,6 +1,10 @@
---- st2205tool/Makefile.orig   2008-01-22 00:43:38.000000000 +0100
-+++ st2205tool/Makefile        2008-04-22 16:01:46.000000000 +0200
-@@ -6,26 +6,26 @@
+---
+ Makefile |   20 ++++++++++----------
+ 1 file changed, 10 insertions(+), 10 deletions(-)
+
+--- st2205tool.orig/Makefile
++++ st2205tool/Makefile
+@@ -6,27 +6,27 @@ LIBS =
  all:  libst2205/libst2205.so setpic/setpic phack splice bgrep
  
  install: all
@@ -11,8 +15,9 @@
 -      make -C libst2205
 +      $(MAKE) -C libst2205
  
- setpic/setpic:
+-setpic/setpic:
 -      make -C setpic
++setpic/setpic: libst2205/libst2205.so
 +      $(MAKE) -C setpic
  
  phack:        $(OBJ) $(SRC)
@@ -35,3 +40,6 @@
        rm -f $(OBJ) phack splice splice.o bgrep bgrep.o
  
  distclean: clean
+-      rm -f fwimage.bak memimage.bak fwimage.bin
+\ No newline at end of file
++      rm -f fwimage.bak memimage.bak fwimage.bin