Add missing dependecy on xbitmaps to xsetroot.
authorLars-Peter Clausen <lars@metafoo.de>
Wed, 17 Sep 2008 18:30:02 +0000 (18:30 +0000)
committerLars-Peter Clausen <lars@metafoo.de>
Wed, 17 Sep 2008 18:30:02 +0000 (18:30 +0000)
SVN-Revision: 12618

XOrg/app/xsetroot/Makefile

index bad5149b10088a97d4ab5420b6c27bcc74bd8353..6a39b4f4418379dd6c63515250a27be2b7bcdcd6 100644 (file)
@@ -1,10 +1,11 @@
-# 
-# Copyright (C) 2007 OpenWrt.org
+#
+# Copyright (C) 2007-2008 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# blogic@openwrt.org 
+# blogic@openwrt.org
+# $Id$
 
 include $(TOPDIR)/rules.mk
 
@@ -14,20 +15,24 @@ PKG_RELEASE:=2
 PKG_VERSION:=1.0.2
 PKG_SOURCE_URL:=http://xorg.freedesktop.org/releases/X11R7.3/src/app
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
-PKG_BUILD_DIR=$(BUILD_DIR)/Xorg/$(_CATEGORY)/${PKG_NAME}-$(PKG_VERSION)/
+PKG_BUILD_DIR=$(BUILD_DIR)/Xorg/$(_CATEGORY)/$(PKG_NAME)-$(PKG_VERSION)/
 
-_DEPEND:= +libX11
+_DEPEND:= +libX11 +xbitmaps
 ifneq (xsetroot,xinit)
 _DEPEND+=xorg-server-essentials
 endif
 
 include $(INCLUDE_DIR)/package.mk
 
+TARGET_LDFLAGS+=-Wl,-rpath-link=$(STAGING_DIR)/usr/lib
+
+PKG_INSTALL=1
+
 define Package/xsetroot
   SECTION:=xorg-app
   CATEGORY:=Xorg
   SUBMENU:=app
-  DEPENDS:=${_DEPEND} @DISPLAY_SUPPORT
+  DEPENDS:=+libX11 +xbitmaps @DISPLAY_SUPPORT
   TITLE:=xsetroot
   URL:=http://xorg.freedesktop.org/
 endef
@@ -36,27 +41,10 @@ define Build/InstallDev
        DESTDIR=$(1) $(MAKE) -C $(PKG_BUILD_DIR) $(MAKE_FLAGS) install
 endef
 
-ifeq (xsetroot,xdm)
-CONFIGURE_ARGS+=--with-random-device=/dev/urandom
-endif
-
-CONFIGURE_ARGS+=LIBS="-Wl,-rpath-link=$(STAGING_DIR)/usr/lib" 
-
-define Build/Compile
-       make -C $(PKG_BUILD_DIR)
-       make -C $(PKG_BUILD_DIR) DESTDIR=$(PKG_INSTALL_DIR) install
-endef
-
 define Package/xsetroot/install
        $(INSTALL_DIR) $(1)
        $(CP) $(PKG_INSTALL_DIR)/* $(1)
        rm -rf $(1)/usr/man/
 endef
 
-define Package/xinit/install
-       $(INSTALL_DIR) $(1)/usr/bin
-       $(CP) $(PKG_INSTALL_DIR)/usr/bin/xinit $(1)/usr/bin/xinit
-       cd $(1)/usr/bin/; ln -s xinit startx
-endef
-
 $(eval $(call BuildPackage,xsetroot))