[package] allow openvpn to be compiled without LZO support (#7843)
authorFlorian Fainelli <florian@openwrt.org>
Sat, 11 Sep 2010 18:38:49 +0000 (18:38 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Sat, 11 Sep 2010 18:38:49 +0000 (18:38 +0000)
SVN-Revision: 23019

net/openvpn/Makefile

index 109238a812343796f4dacb27ace0fde458aac0cc..7f8ebf2e7bbfa4bb6f0511aeedec75965806f862 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006-2009 OpenWrt.org
+# Copyright (C) 2006-2010 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=openvpn
 PKG_VERSION:=2.1.1
-PKG_RELEASE:=3
+PKG_RELEASE:=4
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://openvpn.net/release @SF/openvpn
@@ -22,12 +22,19 @@ include $(INCLUDE_DIR)/package.mk
 define Package/openvpn
   SECTION:=net
   CATEGORY:=Network
-  DEPENDS:=+kmod-tun +libopenssl +liblzo
+  DEPENDS:=+kmod-tun +libopenssl +PACKAGE_openvpn_complzo:liblzo
   TITLE:=Open source VPN solution using SSL
   URL:=http://openvpn.net
   SUBMENU:=VPN
 endef
 
+define Package/openvpn/config
+config PACKAGE_openvpn_complzo
+       bool "Enable --comp-lzo compression option"
+       depends on PACKAGE_openvpn
+       default y
+endef
+
 define Package/openvpn/conffiles
 /etc/config/openvpn
 endef
@@ -57,6 +64,11 @@ CONFIGURE_ARGS+= \
        --enable-password-save \
        --enable-small
 
+ifndef CONFIG_PACKAGE_openvpn_complzo
+CONFIGURE_ARGS += \
+       --disable-lzo
+endif
+
 define Build/Configure
        $(call Build/Configure/Default, \
                $(CONFIGURE_ARGS) \