ar71xx: set firmware version for the TL-WR2543N
authorGabor Juhos <juhosg@openwrt.org>
Thu, 5 Jul 2012 16:25:31 +0000 (16:25 +0000)
committerGabor Juhos <juhosg@openwrt.org>
Thu, 5 Jul 2012 16:25:31 +0000 (16:25 +0000)
This ensures that the resulting firmware can
be flashed from the latest (v3.13.17) offical
firmware.

SVN-Revision: 32617

target/linux/ar71xx/image/Makefile

index a398242265822434ab57dfebf4f04d47329d6cbb..6e2180ea8e85f69f024af1e1efe93db1b67f0360 100644 (file)
@@ -425,13 +425,13 @@ endef
 define Image/Build/TPLINK-LZMA
        $(call PatchKernelLzma,$(2),$(3))
        -$(STAGING_DIR_HOST)/bin/mktplinkfw \
-               -H $(4) -W $(5) -F $(6) -N OpenWrt -V $(REVISION)\
+               -H $(4) -W $(5) -F $(6) -N OpenWrt -V $(REVISION) $(7) \
                -k $(KDIR_TMP)/vmlinux-$(2).bin.lzma \
                -r $(KDIR)/root.$(1) \
                -a $(call rootfs_align,$(1)) -j \
                -o $(call factoryname,$(1),$(2))
        -$(STAGING_DIR_HOST)/bin/mktplinkfw \
-               -H $(4) -W $(5) -F $(6) -N OpenWrt -V $(REVISION) -s \
+               -H $(4) -W $(5) -F $(6) -N OpenWrt -V $(REVISION) $(7) -s \
                -k $(KDIR_TMP)/vmlinux-$(2).bin.lzma \
                -r $(KDIR)/root.$(1) \
                -a $(call rootfs_align,$(1)) -j \
@@ -441,7 +441,7 @@ endef
 define Image/Build/TPLINK-LZMA/initramfs
        $(call PatchKernelLzma,$(2),$(3))
        -$(STAGING_DIR_HOST)/bin/mktplinkfw -c \
-               -H $(4) -W $(5) -F $(6) -N OpenWrt -V $(REVISION) -s \
+               -H $(4) -W $(5) -F $(6) -N OpenWrt -V $(REVISION) $(7) -s \
                -k $(KDIR_TMP)/vmlinux-$(2).bin.lzma \
                -o $(call imgname,$(1),$(2))-uImage.bin
 endef
@@ -984,7 +984,7 @@ endef
 
 tlwr2543_cmdline=board=TL-WR2543N console=ttyS0,115200
 define Image/Build/Profile/TLWR2543
-       $(call Image/Build/Template/$(fs_64kraw)/$(1),TPLINK-LZMA,tl-wr2543n-v1,$(tlwr2543_cmdline),0x25430001,1,8Mlzma)
+       $(call Image/Build/Template/$(fs_64kraw)/$(1),TPLINK-LZMA,tl-wr2543n-v1,$(tlwr2543_cmdline),0x25430001,1,8Mlzma,-v 3.13.99)
 endef
 
 tlwdr4300_cmdline=board=TL-WDR4300 console=ttyS0,115200