Rename matchbox to matchbox-window-manager as suggested by hanez since its the
authorLars-Peter Clausen <lars@metafoo.de>
Sun, 4 Jan 2009 21:00:38 +0000 (21:00 +0000)
committerLars-Peter Clausen <lars@metafoo.de>
Sun, 4 Jan 2009 21:00:38 +0000 (21:00 +0000)
actuall package name and better fits the naming scheme of soon to be added
matchbox packages.

SVN-Revision: 13865

Xorg/wm/matchbox-window-manager/Makefile [new file with mode: 0644]
Xorg/wm/matchbox/Makefile [deleted file]

diff --git a/Xorg/wm/matchbox-window-manager/Makefile b/Xorg/wm/matchbox-window-manager/Makefile
new file mode 100644 (file)
index 0000000..e59d5c3
--- /dev/null
@@ -0,0 +1,47 @@
+#
+# Copyright (C) 2007-2008 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+# blogic@openwrt.org
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=matchbox-window-manager
+PKG_VERSION:=1.2
+PKG_RELEASE:=1
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
+PKG_SOURCE_URL:=http://matchbox-project.org/sources/matchbox-window-manager/$(PKG_VERSION)
+
+PKG_FIXUP = libtool
+
+TARGET_LDFLAGS+= \
+       -Wl,-rpath-link=$(STAGING_DIR)/usr/lib \
+       -Wl,-rpath-link=$(STAGING_DIR)/usr/lib/libiconv/lib \
+       -Wl,-rpath-link=$(STAGING_DIR)/usr/lib/libintl/lib
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/matchbox-window-manager
+  TITLE:=matchbox window manager
+  SECTION:=xorg-wm
+  CATEGORY:=Xorg
+  SUBMENU:=window manager
+  DEPENDS:=+libX11 +zlib +libfreetype +fontconfig +libmatchbox
+endef
+
+define Build/Compile
+       $(MAKE) -C $(PKG_BUILD_DIR) \
+               DESTDIR="$(PKG_INSTALL_DIR)" \
+               LIBMB_LIBS="-L$(STAGING_DIR)/usr/lib -lfontconfig -lXrender -lz -lexpat -lfreetype -lXft -lmb -lX11 -lXext -lXau -lXdmcp -lpng12" \
+               all install 
+endef
+
+define Package/matchbox-window-manager/install
+       $(INSTALL_DIR) $(1)/
+       $(CP) $(PKG_INSTALL_DIR)/* $(1)/
+endef
+
+$(eval $(call BuildPackage,matchbox-window-manager))
diff --git a/Xorg/wm/matchbox/Makefile b/Xorg/wm/matchbox/Makefile
deleted file mode 100644 (file)
index 1149517..0000000
+++ /dev/null
@@ -1,47 +0,0 @@
-#
-# Copyright (C) 2007-2008 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-# blogic@openwrt.org
-
-include $(TOPDIR)/rules.mk
-
-PKG_NAME:=matchbox-window-manager
-PKG_VERSION:=1.2
-PKG_RELEASE:=1
-
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
-PKG_SOURCE_URL:=http://matchbox-project.org/sources/matchbox-window-manager/$(PKG_VERSION)
-
-PKG_FIXUP = libtool
-
-TARGET_LDFLAGS+= \
-       -Wl,-rpath-link=$(STAGING_DIR)/usr/lib \
-       -Wl,-rpath-link=$(STAGING_DIR)/usr/lib/libiconv/lib \
-       -Wl,-rpath-link=$(STAGING_DIR)/usr/lib/libintl/lib
-
-include $(INCLUDE_DIR)/package.mk
-
-define Package/matchbox
-  TITLE:=matchbox window manager
-  SECTION:=xorg-wm
-  CATEGORY:=Xorg
-  SUBMENU:=window manager
-  DEPENDS:=+libX11 +zlib +libfreetype +fontconfig +libmatchbox
-endef
-
-define Build/Compile
-       $(MAKE) -C $(PKG_BUILD_DIR) \
-               DESTDIR="$(PKG_INSTALL_DIR)" \
-               LIBMB_LIBS="-L$(STAGING_DIR)/usr/lib -lfontconfig -lXrender -lz -lexpat -lfreetype -lXft -lmb -lX11 -lXext -lXau -lXdmcp -lpng12" \
-               all install 
-endef
-
-define Package/matchbox/install
-       $(INSTALL_DIR) $(1)/
-       $(CP) $(PKG_INSTALL_DIR)/* $(1)/
-endef
-
-$(eval $(call BuildPackage,matchbox))