do not build lib and util here,
authorNicolas Thill <nico@openwrt.org>
Mon, 15 Aug 2005 03:25:51 +0000 (03:25 +0000)
committerNicolas Thill <nico@openwrt.org>
Mon, 15 Aug 2005 03:25:51 +0000 (03:25 +0000)
enable kmod build when target arch != mipsel

SVN-Revision: 1681

openwrt/target/linux/package/fuse/Makefile

index 8b997d6b4fe296223cc9fe698e54c00159f3b0d2..5d1dc89d4176c6a52388119ad684b173483f3f73 100644 (file)
@@ -55,8 +55,8 @@ $(PKG_BUILD_DIR)/.configured:
                  --enable-shared \
                  --enable-static \
                  --enable-kernel-module \
-                 --enable-lib \
-                 --enable-util \
+                 --disable-lib \
+                 --disable-util \
                  --disable-example \
                  --disable-auto-modprobe \
                  --with-kernel=$(KERNEL_DIR) \
@@ -66,6 +66,7 @@ $(PKG_BUILD_DIR)/.configured:
 $(PKG_BUILD_DIR)/.built:
        mkdir -p $(PKG_INSTALL_DIR)
        $(MAKE) -C $(PKG_BUILD_DIR) \
+               ARCH="$(ARCH)" \
                DESTDIR="$(PKG_INSTALL_DIR)" \
                SUBDIRS="kernel" \
                all install