oprofile: reduce package size, adjust linking order to find the right libiberty first
authorFelix Fietkau <nbd@openwrt.org>
Sat, 23 May 2009 00:01:47 +0000 (00:01 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Sat, 23 May 2009 00:01:47 +0000 (00:01 +0000)
SVN-Revision: 16006

devel/oprofile/Makefile

index c3368e7f9faf6bd0dffdac573d0e9a11fb8430e1..af2558c5f03107f1539e3988150d09a52096fa5b 100644 (file)
@@ -51,6 +51,8 @@ define Build/Configure
        )
 endef
 
+TARGET_LDFLAGS := -L$(STAGING_DIR)/usr/lib $(TARGET_LDFLAGS)
+
 define Package/oprofile/install
        $(INSTALL_DIR) $(1)/usr/bin
        $(INSTALL_BIN) \
@@ -64,7 +66,8 @@ define Package/oprofile/install
 
        $(INSTALL_DIR) $(1)/usr/share/oprofile
        $(CP) \
-               $(PKG_INSTALL_DIR)/usr/share/oprofile/* \
+               $(PKG_INSTALL_DIR)/usr/share/oprofile/stl.pat \
+               $(PKG_INSTALL_DIR)/usr/share/oprofile/$(LINUX_KARCH) \
                $(1)/usr/share/oprofile/
 endef