Update weechat: 0.2.4 > 0.2.5
authorOliver Ertl <oliver@ertl-net.net>
Sat, 30 Jun 2007 15:31:25 +0000 (15:31 +0000)
committerOliver Ertl <oliver@ertl-net.net>
Sat, 30 Jun 2007 15:31:25 +0000 (15:31 +0000)
SVN-Revision: 7801

net/weechat/Makefile
net/weechat/patches/001-cross_compiling.patch

index fdcf0b1ecf7559788b8406dd16fdb81779f07b2f..47c190ab368d39776355ba9b8484329d08a57705 100644 (file)
@@ -9,12 +9,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=weechat
-PKG_VERSION:=0.2.4
-PKG_RELEASE:=1
+PKG_VERSION:=0.2.5
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=http://weechat.flashtux.org/download/
-PKG_MD5SUM:=c7c7f89d6dac502ad31d12198a8836c1
+PKG_MD5SUM:=42f96620c3b2fd3dca9768d9ce16dd06
 PKG_CAT:=bzcat
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
@@ -32,30 +32,25 @@ define Package/weechat
   URL:=http://weechat.flashtux.org/
 endef
 
-define Build/Configure 
-       $(call Build/Configure/Default, \
-               --with-debug=0 \
-               --with-libgnutls-prefix=$(STAGING_DIR)/usr \
-               --without-doc-xsl-prefix \
-               --with-libiconv-prefix="$(STAGING_DIR)/usr/lib/libiconv" \
-               --without-libintl-prefix \
-               --disable-aspell \
-               --enable-lua \
-               --with-lua-inc="$(STAGING_DIR)/usr/include" \
-               --with-lua-lib="$(STAGING_DIR)/usr/lib" \
-               --disable-perl \
-               --disable-python \
-               --disable-ruby \
-               , \
-               LIBS="-llua -ldl -lm -L$(STAGING_DIR)/usr/lib/libiconv/lib" \
-       )
-endef
-
-define Build/Compile
-       $(MAKE) -C $(PKG_BUILD_DIR) \
-               DESTDIR="$(PKG_INSTALL_DIR)" \
-               all install
-endef
+CONFIGURE_ARGS += \
+       --with-debug=0 \
+       --with-libgnutls-prefix=$(STAGING_DIR)/usr \
+       --without-doc-xsl-prefix \
+       --with-libiconv-prefix="$(STAGING_DIR)/usr/lib/libiconv" \
+       --without-libintl-prefix \
+       --disable-aspell \
+       --enable-lua \
+       --with-lua-inc="$(STAGING_DIR)/usr/include" \
+       --with-lua-lib="$(STAGING_DIR)/usr/lib" \
+       --disable-perl \
+       --disable-python \
+       --disable-ruby \
+       , \
+       LIBS="-llua -ldl -lm -L$(STAGING_DIR)/usr/lib/libiconv/lib"
+
+MAKE_FLAGS += \
+       DESTDIR="$(PKG_INSTALL_DIR)" \
+       all install
 
 define Package/weechat/install 
        $(INSTALL_DIR) $(1)/usr/bin
index d4d4cadf2d134ebe95b0d0453467e6540cd7a636..515646fd7a5c7c056640a850c1855ac2a018be87 100644 (file)
@@ -1,7 +1,8 @@
-diff -urN weechat-0.2.0/configure weechat-0.2.0.new/configure
---- weechat-0.2.0/configure    2006-08-19 13:22:12.000000000 +0200
-+++ weechat-0.2.0.new/configure        2006-09-17 13:51:42.000000000 +0200
-@@ -29801,8 +29801,7 @@
+Index: weechat-0.2.5/configure
+===================================================================
+--- weechat-0.2.5.orig/configure       2007-06-30 17:15:36.000000000 +0200
++++ weechat-0.2.5/configure    2007-06-30 17:15:36.000000000 +0200
+@@ -29349,8 +29349,7 @@
    { { echo "$as_me:$LINENO: error: cannot run test program while cross compiling
  See \`config.log' for more details." >&5
  echo "$as_me: error: cannot run test program while cross compiling
@@ -11,7 +12,7 @@ diff -urN weechat-0.2.0/configure weechat-0.2.0.new/configure
  else
    cat >conftest.$ac_ext <<_ACEOF
  /* confdefs.h.  */
-@@ -29859,7 +29858,6 @@
+@@ -29407,7 +29406,6 @@
  echo "${ECHO_T}yes" >&6; }
    fi
  fi
@@ -19,7 +20,7 @@ diff -urN weechat-0.2.0/configure weechat-0.2.0.new/configure
  if test "x$iconv_found" = "xno" ; then
     { { echo "$as_me:$LINENO: error:
  *** Iconv headers and/or libraries couldn't be found in your system.
-@@ -29868,8 +29866,7 @@
+@@ -29416,8 +29414,7 @@
  echo "$as_me: error:
  *** Iconv headers and/or libraries couldn't be found in your system.
  *** Try to install them with your software package manager.