[packages] libshout: fix dependencies, libvorbisidec is apparently the wrong lib...
authorJo-Philipp Wich <jow@openwrt.org>
Wed, 15 Dec 2010 13:38:04 +0000 (13:38 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Wed, 15 Dec 2010 13:38:04 +0000 (13:38 +0000)
SVN-Revision: 24606

libs/libshout/Makefile

index 5c7f546..9067d17 100644 (file)
@@ -24,7 +24,7 @@ TARGET_CFLAGS += $(FPIC)
 
 define Package/libshout
   SECTION:=libs
-  DEPENDS:= +libspeex +libtheora +libvorbisidec
+  DEPENDS:= +libspeex +libtheora +libvorbis
   CATEGORY:=Libraries
   TITLE:=Library which can be used to write a source client like ices
   URL:=http://www.icecast.org/download.php
@@ -41,7 +41,7 @@ endef
 define Build/Configure
        $(call Build/Configure/Default, \
                VORBIS_CFLAGS="-I$(STAGING_DIR)/usr/include/tremor/"\
-               VORBIS_LIBS="$(TARGET_LDFLAGS)" \
+               VORBIS_LIBS="$(TARGET_LDFLAGS) -lvorbis" \
                --enable-shared \
                --enable-static \
        )