Add dmidecode (#1776)
authorFlorian Fainelli <florian@openwrt.org>
Sun, 1 Jul 2007 09:08:01 +0000 (09:08 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Sun, 1 Jul 2007 09:08:01 +0000 (09:08 +0000)
SVN-Revision: 7817

utils/dmidecode/Makefile [new file with mode: 0644]

diff --git a/utils/dmidecode/Makefile b/utils/dmidecode/Makefile
new file mode 100644 (file)
index 0000000..00af615
--- /dev/null
@@ -0,0 +1,41 @@
+# 
+# Copyright (C) 2007 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+# $ Id: $
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=dmidecode
+PKG_VERSION:=2.9
+PKG_RELEASE:=1
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
+PKG_SOURCE_URL:=http://download.savannah.gnu.org/releases/dmidecode/
+PKG_MD5SUM:=3dac4b1817012ffebd78671473d8f56c
+PKG_CAT:=bzcat
+
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/dmidecode
+  SECTION:=utils
+  CATEGORY:=Utilities
+  DEPENDS:=@LINUX_2_6_X86
+  TITLE:=Displays BIOS informations.
+  DESCRIPTION:=\
+       Dmidecode reports information about your system's hardware\\\
+       as described in your system BIOS according to the SMBIOS/DMI\\\
+       standard.
+  URL:=http://www.nongnu.org/dmidecode/
+endef
+
+define Package/dmidecode/install
+       $(INSTALL_DIR) $(1)/usr/sbin
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/$(PKG_NAME) $(1)/usr/sbin
+endef
+
+$(eval $(call BuildPackage,dmidecode))