[packages] libiconv: add ASCII as alias to US-ASCII, fixes various glib applications
authorJo-Philipp Wich <jow@openwrt.org>
Thu, 28 Apr 2011 13:54:08 +0000 (13:54 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Thu, 28 Apr 2011 13:54:08 +0000 (13:54 +0000)
SVN-Revision: 26775

libs/libiconv/Makefile
libs/libiconv/src/iconv.c

index 1842ae2553673b83074ce630392ba1da0df18791..6509ce17d5792579c04ebd0f5cfd2fff2aee8ad5 100644 (file)
@@ -11,7 +11,7 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=libiconv
-PKG_RELEASE:=4
+PKG_RELEASE:=5
 
 include $(INCLUDE_DIR)/package.mk
 include $(INCLUDE_DIR)/host-build.mk
index 64009f249f9d033542b782c4c4dbf892420bbda0..8b2bd97d99d3842255a7239e7dd150acd36955c4 100644 (file)
@@ -42,6 +42,7 @@ static const unsigned char charsets[] =
        "\001" "UTF-16LE"   "\0"
        "\002" "UTF-32BE"   "\0"
        "\003" "UTF-32LE"   "\0"
+       "\006" "ASCII"      "\0"
        "\006" "US-ASCII"   "\0"
        "\007" "ISO-8859-1" "\0"
        "\007" "LATIN1"     "\0"