Fix kmod-ipip build (#2092)
authorFlorian Fainelli <florian@openwrt.org>
Thu, 19 Jul 2007 10:01:51 +0000 (10:01 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Thu, 19 Jul 2007 10:01:51 +0000 (10:01 +0000)
SVN-Revision: 8048

package/kernel/modules/network.mk

index 9a3f03f69ab1827e431e6c1d5dd8b6d05c98bf5a..d030080d609c2777c173c2a0432f6b3566355889 100644 (file)
@@ -53,7 +53,6 @@ define KernelPackage/ipip
   KCONFIG:=CONFIG_NET_IPIP
   SUBMENU:=$(NSMENU)
 endef
-$(eval $(call KernelPackage,ipip))
 
 define KernelPackage/ipip/2.4
   FILES:=$(LINUX_DIR)/net/ipv4/ipip.$(LINUX_KMOD_SUFFIX)
@@ -66,7 +65,7 @@ define KernelPackage/ipip/2.6
        $(LINUX_DIR)/net/ipv4/tunnel4.$(LINUX_KMOD_SUFFIX)
   AUTOLOAD:=$(call AutoLoad,30,ipip tunnel4)
 endef
-
+$(eval $(call KernelPackage,ipip))
 
 define KernelPackage/ipsec
   TITLE:=IPsec related modules (IPv4 and IPv6)