[brcm47xx]: generate images for the D-Link DWL-3150 as well
authorImre Kaloz <kaloz@openwrt.org>
Sat, 27 Oct 2012 09:42:58 +0000 (09:42 +0000)
committerImre Kaloz <kaloz@openwrt.org>
Sat, 27 Oct 2012 09:42:58 +0000 (09:42 +0000)
SVN-Revision: 33961

target/linux/brcm47xx/image/Makefile

index 33290ff35a3d68a9bb0b6579902902284cd075b6..871175ed405a50c2bcb3cf940c0fd38ad1e05821 100644 (file)
@@ -1,5 +1,5 @@
-# 
-# Copyright (C) 2006-2010 OpenWrt.org
+#
+# Copyright (C) 2006-2012 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -29,6 +29,11 @@ define Image/Build/wgt634u
        cat $(BIN_DIR)/$(IMG_PREFIX)-$(1).trx >> $(BIN_DIR)/openwrt-wgt634u-$(2).bin
 endef
 
+define Image/Build/dwl3150
+       cp $(BIN_DIR)/$(IMG_PREFIX)-$(1).trx $(BIN_DIR)/openwrt-dwl3150-$(2).bin
+       echo "BCM-5352-2050-0000000-01" >> $(BIN_DIR)/openwrt-dwl3150-$(2).bin
+endef
+
 define Image/Build/CyberTAN
        $(STAGING_DIR_HOST)/bin/addpattern -4 -p $(3) -v v$(4) -i $(BIN_DIR)/$(IMG_PREFIX)-$(1).trx -o $(BIN_DIR)/openwrt-$(2)-$(5).bin $(if $(6),-s $(6))
 endef
@@ -90,6 +95,7 @@ define Image/Build/jffs2-64k
        $(call Image/Build/Motorola,$(1),wa840g,2,$(patsubst jffs2-%,jffs2,$(1)))
        $(call Image/Build/Motorola,$(1),we800g,3,$(patsubst jffs2-%,jffs2,$(1)))
        $(call Image/Build/Edi,$(1),ps1208mfg,$(patsubst jffs2-%,jffs2,$(1)))
+       $(call Image/Build/dwl3150,$(1),$(patsubst jffs2-%,jffs2,$(1)))
 endef
 
 define Image/Build/squashfs