added libast
authorJohn Crispin <john@openwrt.org>
Tue, 9 Oct 2007 22:08:59 +0000 (22:08 +0000)
committerJohn Crispin <john@openwrt.org>
Tue, 9 Oct 2007 22:08:59 +0000 (22:08 +0000)
SVN-Revision: 9230

XOrg/lib/libast/Makefile [new file with mode: 0644]
XOrg/lib/libast/patches/100-configure.patch [new file with mode: 0644]

diff --git a/XOrg/lib/libast/Makefile b/XOrg/lib/libast/Makefile
new file mode 100644 (file)
index 0000000..730a6a9
--- /dev/null
@@ -0,0 +1,66 @@
+# 
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+# blogic@openwrt.org
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=libast
+PKG_VERSION:=0.7
+PKG_RELEASE:=1
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=http://www.eterm.org/download/
+PKG_MD5SUM:=a9ec3b2da317f35869316e6d9571d296
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/libast
+  SECTION:=xorg-libraries
+  CATEGORY:=Xorg
+  SUBMENU:=libraries
+  TITLE:=libast
+  DEPENDS:=+xorg-server-essentials 
+endef
+
+CONFIGURE_ARGS+=dps_cv_snprintf_bug=0 dps_cv_vsnprintf_bug=0 --without-imlib
+
+define Build/Configure
+       (cd $(PKG_BUILD_DIR)/$(CONFIGURE_PATH); \
+               if [ -x $(CONFIGURE_CMD) ]; then \
+                       $(CP) $(SCRIPT_DIR)/config.{guess,sub} $(PKG_BUILD_DIR)/ && \
+                       $(CONFIGURE_VARS) \
+                       $(CONFIGURE_CMD) \
+                               $(CONFIGURE_ARGS_XTRA) \
+                               $(CONFIGURE_ARGS) ;\
+               fi \
+       )
+endef
+
+define Build/Compile
+       $(MAKE) -C $(PKG_BUILD_DIR) \
+               CPPFLAGS="-I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/include" \
+               LDFLAGS="-L$(STAGING_DIR)/usr/lib -L$(STAGING_DIR)/lib"
+       $(MAKE) -C $(PKG_BUILD_DIR) install DESTDIR=$(PKG_INSTALL_DIR)
+endef
+
+define Build/InstallDev
+       $(INSTALL_DIR) $(1)/usr/{lib,include,bin}
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/lib*{la,so}* $(1)/usr/lib
+       $(CP) $(PKG_INSTALL_DIR)/usr/bin/* $(1)/usr/bin
+       $(CP) $(PKG_INSTALL_DIR)/usr/include/* $(1)/usr/include
+       $(SED) "s,"libdir\=\'/usr/lib\'",libdir='$(1)/usr/lib\'," $(1)/usr/lib/libast*.la
+       $(SED) "s,-I/usr/include,,g" $(1)/usr/bin/libast-config
+       $(SED) "s,-L/usr/lib,,g" $(1)/usr/bin/libast-config
+       $(SED) "s,-L/usr/X11R6/lib,,g" $(1)/usr/bin/libast-config
+endef
+
+define Package/libast/install
+       $(INSTALL_DIR) $(1)/usr/lib
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/lib*so* $(1)/usr/lib/
+endef
+
+$(eval $(call BuildPackage,libast))
diff --git a/XOrg/lib/libast/patches/100-configure.patch b/XOrg/lib/libast/patches/100-configure.patch
new file mode 100644 (file)
index 0000000..6da6118
--- /dev/null
@@ -0,0 +1,13 @@
+diff -urN libast-0.7.orig/configure libast-0.7/configure
+--- libast-0.7.orig/configure  2007-10-09 19:54:01.000000000 +0200
++++ libast-0.7/configure       2007-10-09 19:57:29.000000000 +0200
+@@ -23906,7 +23906,7 @@
+         mkdir conftest.d
+         if test "$cross_compiling" = yes; then
+-  dps_cv_symlink_open_buf=3
++  dps_cv_symlink_open_bug=3
+ else
+   cat >conftest.$ac_ext <<_ACEOF
+ /* confdefs.h.  */
+