make nprobe smaller by making mysql support optional and removing unnecessary files...
authorFelix Fietkau <nbd@openwrt.org>
Sun, 29 Mar 2009 05:59:04 +0000 (05:59 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Sun, 29 Mar 2009 05:59:04 +0000 (05:59 +0000)
SVN-Revision: 15068

net/nprobe/Makefile

index 81e7587d8b537290c9982165c23e59bb7ecb22ed..8235c223144b8fdd0910a978c3e1bf98d352df47 100644 (file)
@@ -25,15 +25,26 @@ include $(INCLUDE_DIR)/package.mk
 define Package/nprobe
   SECTION:=utils
   CATEGORY:=Utilities
-  DEPENDS:=+libpcap +libpcre +libpthread +libwrap +libmysqlclient
+  DEPENDS:=+libpcap +libpcre +libpthread +NPROBE_MYSQL_SUPPORT:libmysqlclient
   TITLE:=nProbe
   URL:=http://invisible-island.net/dialog/
 endef
 
+define Package/nprobe/config
+       config NPROBE_MYSQL_SUPPORT
+               depends on PACKAGE_nprobe
+               bool "MySQL support"
+
+endef
+
 define Package/nprobe/description
                nprobe
 endef
 
+ifndef CONFIG_NPROBE_MYSQL_SUPPORT
+  CONFIGURE_VARS += ac_cv_prog_MYSQL=no
+endif
+
 define Build/Configure
        # patch creates these, so we make them executable
        chmod +x $(PKG_BUILD_DIR)/configure
@@ -56,7 +67,7 @@ define Package/nprobe/install
        $(INSTALL_DIR) $(1)/usr/lib
        $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/nprobe \
                $(1)/usr/bin/
-       $(CP) -a $(PKG_INSTALL_DIR)/usr/lib/* \
+       $(CP) -a $(PKG_INSTALL_DIR)/usr/lib/*.so* \
                $(1)/usr/lib
 endef