[package] pppd: use "atmdev" option to select the DSL adapter, this aligns it with...
authorJo-Philipp Wich <jow@openwrt.org>
Wed, 20 Oct 2010 17:56:29 +0000 (17:56 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Wed, 20 Oct 2010 17:56:29 +0000 (17:56 +0000)
SVN-Revision: 23551

package/ppp/Makefile
package/ppp/files/pppoa.sh

index b893b1e..eae32d0 100644 (file)
@@ -10,7 +10,7 @@ include $(INCLUDE_DIR)/kernel.mk
 
 PKG_NAME:=ppp
 PKG_VERSION:=2.4.4
-PKG_RELEASE:=12
+PKG_RELEASE:=13
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=ftp://ftp.samba.org/pub/ppp/
index 59e35c2..df947aa 100644 (file)
@@ -9,8 +9,8 @@ stop_interface_pppoa() {
 setup_interface_pppoa() {
        local config="$2"
 
-       local device
-       config_get device "$config" device
+       local atmdev
+       config_get atmdev "$config" atmdev
 
        local vpi
        config_get vpi "$config" vpi
@@ -34,6 +34,6 @@ setup_interface_pppoa() {
        config_get mtu "$config" mtu
 
        start_pppd "$config" \
-               plugin pppoatm.so ${device:+$device.}${vpi:-8}.${vci:-35} \
+               plugin pppoatm.so ${atmdev:+$atmdev.}${vpi:-8}.${vci:-35} \
                ${encaps} ${mtu:+mtu $mtu mru $mtu}
 }