[packages] gst-plugins-ugly: update to 0.10.15, rework Makefile:
authorNicolas Thill <nico@openwrt.org>
Mon, 5 Jul 2010 01:51:21 +0000 (01:51 +0000)
committerNicolas Thill <nico@openwrt.org>
Mon, 5 Jul 2010 01:51:21 +0000 (01:51 +0000)
 * rename gst-plugins-ugly-* plugins to gst-mod-*
 * add a gst-plugins-ugly meta-package
 * remove unneeded extra CFLAGS & LDFLAGS

SVN-Revision: 22070

multimedia/gst-plugins-ugly/Makefile
multimedia/gst-plugins-ugly/patches/001-no_docs.patch [new file with mode: 0644]
multimedia/gst-plugins-ugly/patches/002-no_tests.patch [new file with mode: 0644]
multimedia/gst-plugins-ugly/patches/020-dont_build_docs.patch [deleted file]
multimedia/gst-plugins-ugly/patches/030-no_shave-make.patch [deleted file]

index 2d6bf601e7ab4570dcd63286e8d354564600a246..d9b9ebf7b5bf0a7b40dee887ab43fe685c82eb6d 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2009 OpenWrt.org
+# Copyright (C) 2009-2010 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=gst-plugins-ugly
-PKG_VERSION:=0.10.13
-PKG_RELEASE:=2
+PKG_VERSION:=0.10.15
+PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=http://gstreamer.freedesktop.org/src/gst-plugins-ugly/
-PKG_MD5SUM:=1619365247ef9cd7da1cd890285bf87a
-PKG_FIXUP:=libtool
-
-include $(INCLUDE_DIR)/package.mk
+PKG_MD5SUM:=21c034a762a5da252f91640e53bfe457
 
-#export PATH:=$(PKG_BUILD_DIR)/bin:$(TARGET_PATH)
+PKG_BUILD_DEPENDS:= gstreamer gst-plugins-base liboil
 
-PKG_INSTALL=1
-
-EXTRA_CFLAGS+= \
-       -I$(STAGING_DIR)/usr/lib/libintl/include \
-       -I$(STAGING_DIR)/usr/lib/libiconv/include \
-       -I$(STAGING_DIR)/usr/include/gtk-2.0/gdk \
-       -I$(STAGING_DIR)/usr/include/gstreamer-0.10
+PKG_FIXUP:=libtool
+PKG_INSTALL:=1
 
-EXTRA_LDFLAGS+= \
-       -Wl,-rpath-link=$(STAGING_DIR)/usr/lib \
-       -L$(STAGING_DIR)/usr/lib/libintl/lib \
-       -L$(STAGING_DIR)/usr/lib/libiconv/lib
+include $(INCLUDE_DIR)/package.mk
 
-define Package/gst-plugins-ugly/Default
-  TITLE:=gst-plugins-ugly
+define Package/gstreamer/Default
+  CATEGORY:=Multimedia
+  SECTION:=multimedia
+  TITLE:=GStreamer
   URL:=http://gstreamer.freedesktop.org/
 endef
 
-define Package/gst-plugins-ugly-lame
-  $(call Package/gst-plugins-ugly/Default)
-  SECTION:=multimedia
-  CATEGORY:=Multimedia
-  TITLE+= (lame)
-  DEPENDS:=+gstreamer +lame-lib
+define Package/gstreamer/description/Default
+ GStreamer open source multimedia framework
 endef
 
-define Package/gst-plugins-ugly-lame/description
-       gstreamer MP3 encoder plugin
+
+define Package/gst-plugins-ugly
+$(call Package/gstreamer/Default)
+  TITLE+= plugins collection (ugly)
+  DEPENDS+= $(GST_DEPENDS)
 endef
 
-define Package/gst-plugins-ugly-mad
-  $(call Package/gst-plugins-ugly/Default)
-  SECTION:=multimedia
-  CATEGORY:=Multimedia
-  TITLE+= (mad)
-  DEPENDS:=+gstreamer +gst-plugins-base-libgsttag +gst-plugins-base-libgstaudio +gst-plugins-base-libgstinterfaces +libmad +libid3tag
+define Package/gts-plugins-ugly/description
+$(call Package/gstreamer/description/Default)
+ .
+ This meta package contains only dependencies to the other plugins from
+ the ugly plugins collection.
 endef
 
-define Package/gst-plugins-ugly-mad/description
-=
-       gstreamer MP3 decoder plugins
+
+GST_VERSION:=0.10
+
+CONFIGURE_ARGS += \
+       --disable-debug \
+       --disable-examples \
+       \
+       --disable-a52dec \
+       --disable-amrnb \
+       --disable-amrwb \
+       --disable-asfdemux \
+       --disable-cdio \
+       --disable-dvdlpcmdec \
+       --disable-dvdread \
+       --disable-dvdsub \
+       --disable-iec958 \
+       --disable-mpeg2dec \
+       --disable-mpegaudioparse \
+       --disable-mpegstream \
+       --disable-realmedia \
+       --disable-sidplay \
+       --disable-synaesthesia \
+       --disable-twolame \
+       --disable-x264 \
+       \
+       --without-libiconv-prefix \
+       --without-libintl-prefix \
+       --without-x \
+
+EXTRA_LDFLAGS+= \
+       -Wl,-rpath-link=$(STAGING_DIR)/usr/lib \
+
+
+define Package/gst-plugins-ugly/install
+       /bin/true
 endef
 
-define Build/Configure
-       $(call Build/Configure/Default, \
-               --disable-pango \
-               --disable-gnome_vfs \
-               --disable-examples \
-               --disable-cdparanoia \
-               --disable-libvisual \
-               --disable-oggtest \
-               --disable-vorbistest \
-               --disable-freetypetest \
-               --without-x \
+
+# 1: short name
+# 2: description
+# 3: dependencies on other gstreamer libraries (short name)
+# 4: dependencies on other gstreamer plugins (short name)
+# 5: dependencies on other packages
+define GstBuildPlugin
+
+  GST_DEPENDS += +gst-mod-$(1)
+
+  define Package/gst-mod-$(1)
+    $(call Package/gstreamer/Default)
+    TITLE+= $(2) plugin (ugly)
+    DEPENDS+= +libgstreamer $$(foreach p,$(3),+libgst$$(p)) $$(foreach p,$(4),+gst-mod-$$(p)) $(5)
+  endef
+
+  define Package/gst-mod-$(1)/description
+   $(call Package/gstreamer/description/Default)
+   .
+   This package contains the GStreamer $(2) plugin.
+  endef
+
+  define Package/gst-mod-$(1)/install
+       $(INSTALL_DIR) $$(1)/usr/lib/gstreamer-$(GST_VERSION)
+       ( cd $(PKG_INSTALL_DIR); $(CP) \
+               ./usr/lib/gstreamer-$(GST_VERSION)/libgst$(1).so* \
+               $$(1)/usr/lib/gstreamer-$(GST_VERSION)/ \
        )
-       mkdir -p $(PKG_BUILD_DIR)/bin
-       touch $(PKG_BUILD_DIR)/bin/gtkdoc-reugly
-       chmod +x $(PKG_BUILD_DIR)/bin/gtkdoc-reugly
-endef
+  endef
 
-define Package/gst-plugins-ugly-lame/install
-       $(INSTALL_DIR) $(1)/usr/lib/gstreamer-0.10
-       $(CP) \
-               $(PKG_INSTALL_DIR)/usr/lib/gstreamer-0.10/libgstlame.so \
-               $(1)/usr/lib/gstreamer-0.10
+  $$(eval $$(call BuildPackage,gst-mod-$(1)))
 endef
 
-define Package/gst-plugins-ugly-mad/install
-       $(INSTALL_DIR) $(1)/usr/lib/gstreamer-0.10
-       $(CP) \
-               $(PKG_INSTALL_DIR)/usr/lib/gstreamer-0.10/libgstmad.so \
-               $(1)/usr/lib/gstreamer-0.10
-endef
+$(eval $(call GstBuildPlugin,lame,MP3 encoder (using LAME),,,+lame-lib))
+$(eval $(call GstBuildPlugin,mad,MP3 decoder (using MAD),audio tag,,+libid3tag +libmad))
 
-$(eval $(call BuildPackage,gst-plugins-ugly-lame))
-$(eval $(call BuildPackage,gst-plugins-ugly-mad))
+$(eval $(call BuildPackage,gst-plugins-ugly))
diff --git a/multimedia/gst-plugins-ugly/patches/001-no_docs.patch b/multimedia/gst-plugins-ugly/patches/001-no_docs.patch
new file mode 100644 (file)
index 0000000..1810542
--- /dev/null
@@ -0,0 +1,22 @@
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -1,7 +1,7 @@
+ DISTCHECK_CONFIGURE_FLAGS=--enable-gtk-doc
+ SUBDIRS = \
+-      gst-libs gst ext docs m4 tests common po
++      gst-libs gst ext m4 tests common po
+ # include before EXTRA_DIST for win32 assignment
+ include $(top_srcdir)/common/win32.mak
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -395,7 +395,7 @@ top_builddir = @top_builddir@
+ top_srcdir = @top_srcdir@
+ DISTCHECK_CONFIGURE_FLAGS = --enable-gtk-doc
+ SUBDIRS = \
+-      gst-libs gst ext docs m4 tests common po
++      gst-libs gst ext m4 tests common po
+ # the MANIFEST contains all win32 related files that should be disted
diff --git a/multimedia/gst-plugins-ugly/patches/002-no_tests.patch b/multimedia/gst-plugins-ugly/patches/002-no_tests.patch
new file mode 100644 (file)
index 0000000..c7eed9d
--- /dev/null
@@ -0,0 +1,22 @@
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -1,7 +1,7 @@
+ DISTCHECK_CONFIGURE_FLAGS=--enable-gtk-doc
+ SUBDIRS = \
+-      gst-libs gst ext m4 tests common po
++      gst-libs gst ext m4 common po
+ # include before EXTRA_DIST for win32 assignment
+ include $(top_srcdir)/common/win32.mak
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -395,7 +395,7 @@ top_builddir = @top_builddir@
+ top_srcdir = @top_srcdir@
+ DISTCHECK_CONFIGURE_FLAGS = --enable-gtk-doc
+ SUBDIRS = \
+-      gst-libs gst ext m4 tests common po
++      gst-libs gst ext m4 common po
+ # the MANIFEST contains all win32 related files that should be disted
diff --git a/multimedia/gst-plugins-ugly/patches/020-dont_build_docs.patch b/multimedia/gst-plugins-ugly/patches/020-dont_build_docs.patch
deleted file mode 100644 (file)
index aef5921..0000000
+++ /dev/null
@@ -1,24 +0,0 @@
-diff -u --recursive gst-plugins-ugly-0.10.13-vanilla/Makefile.am gst-plugins-ugly-0.10.13/Makefile.am
---- gst-plugins-ugly-0.10.13-vanilla/Makefile.am       2009-11-28 15:17:59.253116063 -0500
-+++ gst-plugins-ugly-0.10.13/Makefile.am       2009-11-28 15:19:16.508246874 -0500
-@@ -1,7 +1,7 @@
- DISTCHECK_CONFIGURE_FLAGS=--enable-gtk-doc
- SUBDIRS = \
--      gst-libs gst ext docs m4 tests common po
-+      gst-libs gst ext m4 tests common po
- # include before EXTRA_DIST for win32 assignment
- include $(top_srcdir)/common/win32.mak
-diff -u --recursive gst-plugins-ugly-0.10.13-vanilla/Makefile.in gst-plugins-ugly-0.10.13/Makefile.in
---- gst-plugins-ugly-0.10.13-vanilla/Makefile.in       2009-11-28 15:17:59.208114358 -0500
-+++ gst-plugins-ugly-0.10.13/Makefile.in       2009-11-28 15:19:23.945116771 -0500
-@@ -356,7 +356,7 @@
- top_srcdir = @top_srcdir@
- DISTCHECK_CONFIGURE_FLAGS = --enable-gtk-doc
- SUBDIRS = \
--      gst-libs gst ext docs m4 tests common po
-+      gst-libs gst ext m4 tests common po
- # the MANIFEST contains all win32 related files that should be disted
diff --git a/multimedia/gst-plugins-ugly/patches/030-no_shave-make.patch b/multimedia/gst-plugins-ugly/patches/030-no_shave-make.patch
deleted file mode 100644 (file)
index 0695a22..0000000
+++ /dev/null
@@ -1,16 +0,0 @@
-diff -u --recursive gst-plugins-ugly-0.10.13-vanilla/common/shave-libtool.in gst-plugins-ugly-0.10.13/common/shave-libtool.in
---- gst-plugins-ugly-0.10.13-vanilla/common/shave-libtool.in   2009-11-28 15:17:59.166114391 -0500
-+++ gst-plugins-ugly-0.10.13/common/shave-libtool.in   2009-11-28 15:20:46.244261210 -0500
-@@ -41,12 +41,9 @@
- case "$mode" in
- compile)
--    # shave will be called and print the actual CC/CXX/LINK line
--    preserved_args="$preserved_args --shave-mode=$mode"
-     pass_though=1
-     ;;
- link)
--    preserved_args="$preserved_args --shave-mode=$mode"
-     Q="  LINK  "
-     ;;
- *)